Support » Fixing WordPress » Fatal error: Call to a member function on a non-object

  • Hello… I get this fatal error when I click on the Presentation tab while logged in to wp-admin:

    Fatal error: Call to a member function on a non-object in /home/content/l/u/x/luxout/html/wp-includes/functions.php on line 1489

    I just installed WordPress 1.5.1 yesterday and everything was working fine. Then I logged on today and started getting that fatal error message when I click on the Presentation link to edit my themes.
    I’ve looked at line 1489 of the function.php file and it is identical (unchanged) to the one I originally downloaded yesterday. I also reinstalled the entire WordPress 1.5.1 application and I still have the same problem. My URL is

    Any ideas are much appreciated, thank you!

Viewing 15 replies - 1 through 15 (of 15 total)
  • skippy



    Frist, try upgrading to That might resolve the problem. If not, I suspect it’s a problem in a theme somewhere.

    Thanks, but I am already running, I thought it may be a problem with a theme as well, so I deleted all of the themes I had uploaded, leaving only the themes that were included in the original downloaded file but it still gives me the same error.

    same here. Uploaded a few themes, suddenly I get this error.

    Here are the themes I uploaded:

    expanded them all, then I got this error.

    sorry for the double post.

    upgraded to .2, same error:

    Fatal error: Call to a member function on a non-object in /home/xxx/public_html/mynn/wp-includes/functions.php on line 1491

    okay, I deleted “summertime” and that fixed it.

    I have the same problem. I just installed and clicking on the Presentation tab brings up the same error. I’m using the default install with the default themes. Any luck with the cause? I think it might have something to do with running PHP in safe mode (which I can’t control due to my host).

    I guess I maybe answered the wrong thread before, but check the chown/chgrp/chmod for any theme dir that you upload because I had this same problem but fixed it as per post here..


    This solved my problem :

    You should check this directory /wordpress/wp-content/themes/ on your FTP and compare it with the original directory in the zip file on your harddrive. In this directory you should find the following subdirectories : classic & default. I found one empty subdir that carried the same name i had given to my blog site. I never created that directory so i guess it was created somewhere during the install. If you delete this subdir your problem should be solved.


    Seems to solve this if you set your permissions for wp-content to 777. Not sure why this is the case, though…



    still having the same issue on a fresh install. no issues with the directories, set permissions to 777, not quite sure what else i can do here. Ideas?



    Misha: fresh install, which version? 1.5.2 or 2.0?



    2.0 most recently. I put it on a whole new database and that didnt fix anything either.



    ok i think i am through with WP. I deleted all fo the files in the ftp space from 2.0 and put in the files from the last stable version of wp. same issue. I am totally lost. I think I am just going to redesign my entire website and not use WP. This is insane. Anyone know of any other fixes? Shoot, at this point I will let you set the thing up on my space and you can tell me what i am doing wrong in all of this.. Any takers?

    i get this error when i try to use the WP header on 4images.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Fatal error: Call to a member function on a non-object’ is closed to new replies.