WordPress.org

Forums

Wordfence Security
[resolved] Fatal error: Allowed memory size with latest update (17 posts)

  1. Stever22
    Member
    Posted 8 months ago #

    On one of my wordpress sites I am getting the following error:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 188 bytes) in /home/XXXX/public_html/wp-content/plugins/wordfence/lib/wfBrowscapCache.php on line 50567)

    The server has only 64Meg but with a utility I do have 13 meg free. I have change the setting in options to allow only 5 meg for wordfence but I still get this error when accessing the website. I don't have cache enabled.
    Only way around it is to disable the wordfence add-on.

    Thanks,

    Steve

    https://wordpress.org/plugins/wordfence/

  2. barnez
    Member
    Posted 8 months ago #

    Try disabling "Live Traffic"
    Also: Go to Wordfence options. Scroll to the bottom of the page and find:

    Update interval in seconds (2 is default)

    Set this update interval to something like 30 seconds (just enter the number 30) which will cause a hit every 30 seconds when you're watching live traffic. That should keep your web host happy.

    http://wordpress.org/support/topic/increased-load-on-the-server?replies=4

  3. Oddly Active
    Member
    Posted 8 months ago #

    Hi - I'm having same problem with latest update.

    I have tried disabling live traffic and changing the update interval to 30 seconds but still getting fatal error...

    Any other suggestions?

  4. Wordfence
    Member
    Plugin Author

    Posted 8 months ago #

    Hi,

    This has nothing to do with update interval. Your server is running out of memory and 64 megs is not enough to run a complex WordPress site with Wordfence.

    You're going to have to upgrade it to 128 megs. Then make sure you adjust memory_limit in your PHP.ini file and restart your web server. Then try another scan and you should not run out of memory.

    Regards,

    Mark.

  5. Oddly Active
    Member
    Posted 8 months ago #

    Hi - this is NOT what's causing the issue (unless I'm missing something?)as the setting under 'maximum memory wordfence can use' is 256Mb - i.e. twice what you have quoted. I haven't adjusted the 'PHP.ini file' because a) the maximum memory has been 256Mb since the website was first created and this hasn't been an issue before and b) I haven't a clue what the PHP.ini file is/how to adjust it/why I should need to...

    I changed the update interval because it was a suggested fix. But it didn't work. The issue I have hasn't been an issue prior to updating to the latest release, so the natural assumption is that the 'bug' was introduced with the latest release, which is what Stever 22 seems to be saying too and within exactly the same time period. If there's a way I can rewind to the previous (and, on my site at least, stable) version of Wordfence I'll try that and wait to update manually until the next release in the hope that whatever's causing the problem is resolved.

    Any other suggestions greatly appreciated, but for now i've had to deactivate wordfence and install a different security plug in. It's either that, or I have no site.

  6. barnez
    Member
    Posted 8 months ago #

    @Oddly Active

    In the Developers tab of each plugin on wordpress.org you can find zip files of the recent plugin versions. You could upload 5.1.4 into your plugins list, activate it and see if it resolves your issue.

    http://downloads.wordpress.org/plugin/wordfence.5.1.4.zip

    *Edited*

  7. aigarinsh
    Member
    Posted 8 months ago #

    Same problem here. Have not had any problems before with other hosts. Don't know how much memory was available there, but on this one I get the same error with text "67108864 bytes exhausted". I have set in Wordfence Options maximum available 24, but still get the same error. Tried wordfence.5.1.4.zip still the same problem.

  8. Stever22
    Member
    Posted 8 months ago #

    I had my webhost increase the memory to 128 Meg and now the error has gone away. I tried all the other suggestions above before memory increase and it never helped. I believe its related to the amount of memory that you have free. I use an add-on called Server IP and Memory Usage (http://apasionados.es/#utm_source=wpadmin&utm_medium=plugin&utm_campaign=server-ip-memory-usage-plugin) and before with 64meg I had less then 10% free. Now I have 60%. Also I set the max memory that Wordfence to use to 20Meg but during a scan it says it used over 32Meg of memory to scan.This limit really does nothing for me. Oddly Active says he has 255Meg and still gets the error. How much memory do you have free?

    Thanks,

    Steve

  9. aigarinsh
    Member
    Posted 8 months ago #

    I haven't had problems before with default 256 setting and 96 which is something I usually set. But really don't have a clue how much server can grant (how can I test or where to see it?), because it has never been an issue for me. This is the first time when server can't cope with the needs.

  10. sdayman
    Member
    Posted 8 months ago #

    @ aigarinsh, go to the Wordfence Options page and click the link at the bottom: "Test your WordPress host's available memory"
    That should show you what php.ini will let you have, then test the typical amount of memory Wordfence uses.

  11. Stever22
    Member
    Posted 8 months ago #

    Interesting. I just checked another website I maintain. It has the latest Wordfence installed. It also only has 64Meg on the server and it seems to be working fine (except when I run a scan). My other with 64Meg would not even open unless I logged in. Now this site has very limited add-ons. Its using 33meg of the 64 meg. Again I still believe it has to do what is free. I ran the Test your wordpress host's available memory and it fails with a similar error message but at least the website runs OK.
    My conclusion is Wordfence is a pig on memory. You can set the maximum memory that wordfence can use to whatever and it does not really do anything. You need free memory.
    Wordfence. What does the maximum memory that wordfence can use really do?

  12. aigarinsh
    Member
    Posted 8 months ago #

    @sdayman
    I did the "Test your WordPress host's available memory" and here is what I got:
    Current maximum memory configured in php.ini: 67108864
    Current memory usage: 43.75M
    Setting max memory to 90M.
    And after that Fatal error: Allowed memory size of 67108864 bytes exhausted.
    So the question arises - why Wordfence during this test set the max memory to 90M if I have set to use only 24M? Any ideas?
    When I disable live traffic logging and automatic scans, error is gone, but then what's the point of having Wordfence activated if I can't scan and see those loggs?

  13. ottomek
    Member
    Posted 8 months ago #

    I too have php.ini set at 256M and I get Fatal error: Allowed memory size of 67108864 bytes exhausted.

    Funny thing is I have about 15 others sites on this same web host running Wordfence and this is only happening to 1 site.

    None of the tweaks above fixed it.

  14. nickcav
    Member
    Posted 8 months ago #

    I only just updated wordfense 10 mins ago and now I see this error, I've never had a problem before. I'm sorry Mark but telling us this has nothing to do with the update just makes you look like you're avoiding an issue and not giving any support. Clearly there is something wrong with the latest update!

  15. ww1daily
    Member
    Posted 8 months ago #

    Personally I'm with Nickcav on this one. Have a dedicated server with loads of memory and a lot allocated but am still getting errors which only go away when I deactivate.

  16. barnez
    Member
    Posted 8 months ago #

    For what it's worth, I use the latest version of Wordfence without any problems on two shared hosting sites with 80.25 megabytes of memory available for each PHP process.

  17. solmark
    Member
    Posted 1 month ago #

    I had the same issue. In the Wordfence settings it stated 256 mb, but when I clicked the link in the Wordfence options to check what my host had allocated, it stated 32mb. I contacted my host and asked them to increase it to 128mb, which they did and my issue is resolved.

Reply

You must log in to post.

About this Plugin

About this Topic