Support » Fixing WordPress » Fatal error: Allowed memory size […] on wp-includes/wp-db.php

  • alfredopacino

    (@alfredopacino)


    Hi, I’m struggling in weeks with this problem.
    What could be the case?

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 108585 bytes) in /mysite/wp-includes/wp-db.php on line 1837

Viewing 3 replies - 1 through 3 (of 3 total)
  • Exhausted memory is often a good indication of an infinite loop in your code.

    First try deactivating all plugins to rule-out a plugin-specific issue and try switching themes to rule-out a theme-specific issue.

    If that doesn’t work, check your database for massive tables. The wp_options table can get bloated with autoloaded options sometimes when a plugin malfunctions.

    You can try upping the allowed memory size from 256M to 512M to see if that helps with your problem, but 256M should definitely be enough for most cases.

    alfredopacino

    (@alfredopacino)

    Checking my db I’m pretty sure it comes from post table
    http://www.awesomescreenshot.com/image/1746541/cacc3e5440dbccce96f060da1ba4c5a7

    wp_options have 454 rows/2.6MiB

    alfredopacino

    (@alfredopacino)

    any tip about this problem?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal error: Allowed memory size […] on wp-includes/wp-db.php’ is closed to new replies.