Support » Localhost Installs » Fatal error: Allowed memory size of bytes exhausted

  • Hello,
    Can someone help me in solving next issue.
    Situation is as follows.
    I’ve Copied my entire productionsite to my localhost but just cannot figure out why this memory problem keeps popping up (It’s trying to allocate a HUGE amount of memory size).

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 21392424651980930 bytes) in C:\Bitnami\wampstack-7.1.14-0\apache2\htdocs\mysite\wp-includes\functions.php on line 5231

    I have looked for a simular topic but did not find anything useful to me.
    I just don’t know where to start in solving this problem anymore. Help!

    Someone out there facing a same kind of issue (allocating ridiculous high memory size + problem tackled in \includes\functions.php)?

Viewing 7 replies - 1 through 7 (of 7 total)
  • First, disable all plugins. If you copied your production site, including the database, it might be a plugin issues.

    Also, check your PHP memory.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    See http://www.wpbeginner.com/plugins/how-to-deactivate-all-plugins-when-not-able-to-access-wp-admin/

    This is a known issue:

    https://core.trac.wordpress.org/ticket/44532
    https://bugs.php.net/bug.php?id=72451

    Perhaps WP should hardcode a list of wrappers into the offending function ASAP, then revert to the original function after the bug is permanently fixed in PHP…

    First I would like to thank you all for trying helping me out!
    Disconnecting plugins and current theme is what I did at first try (the most common answer related to memory usage you will find on the net). However the problem still raised even using the twentyseventeen theme.
    Also copying ‘fresh’ wordpress files (wp-admin, wp-includes and root files) reconfiguring the wp-config plus a clean .htaccess file didn’t solve the case.

    To Dion; Yes, It’s indeed about the ridiculous memory usage. Thanks for posting this message! I will try your method and post my result. Note however the first fatal error was a little bit different:
    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 21392424651980930 bytes) in C:\Bitnami\wampstack-7.1.14-0\apache2\htdocs\mysite\wp-includes\functions.php on line 5231

    Thank you Steve for the links and your help!

    Keita

    DionDesigns Thanks! This was realy helpful.
    I have reverted WordPress to version 4.9.6 and all works fine again (although my production-site did not had the problem, guess it is not running on windows-server ;-)).
    This is a major issue for the layman (me), hope WP will catch-up soon.

    It seems the problem stays after all 🙁 also after a downgrade to 4.9.6.
    Although it took some time the server crashed this time…at first instance it looked allright.
    Somebody knows the status of this major bug?
    Hope someone will respond.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Support Volunteer

    In that case, it’s some other issue.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.