Support » Plugin: Yoast SEO » FATAL ERROR: Allowed memory size of 805306368 bytes exhausted

  • Resolved Kevin Mamaqi

    (@kevinmamaqi)


    I receive the following error when activating WP SEO:

    FATAL ERROR: Allowed memory size of 805306368 bytes exhausted (tried to allocate 8319100054830872200 bytes) in /…/zarza/wp-admin/menu-header.php on line 96

Viewing 8 replies - 16 through 23 (of 23 total)
  • Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    @fandangointeractive I think that in both cases it’s another plugin malfunctioning. I would recommend opening another thread for this or evenmore disabling your plugins one by one until you figure out which one is causing the problem. I have a lot of personal sites running on PHP7.0, all on SiteGround and I haven’t had a single issue with that. Needless to say, I have Yoast on all of them.

    @stodorovic On SiteGround, you can create a local php.ini file with this line in it and test it out:
    opcache.enabled=0
    You can actually set it via the cPanel variable manager recursively. However, I would actually test out each plugin I am using before doing this. Default WP + Yoast will not throw such errors, I am sure of it. Actually, just tested it and it doesn’t behave like that at all.

    @kevinmamaqi – Do you get the same error if you disable Wordfence and then enable Yoast?

    You need to open File Manager ( https://www.siteground.com/tutorials/cpanel/file_manager.htm ), then check “Show Hidden Files (dotfiles)” and open your home directory. You should see subdirectory .opcache, enter to this directory and remove directory which you see there (it’s something like b8f0bb764a038db03dfc2c58077eebbc). It’s way how you can purge opcache.

    Related to disabling opcache, enter to public_html and find file php.ini. Try to put this line in php.ini:

    opcache.enable = 0

    If you find zend_extension = opcache.so there, then remove this line or change to ;zend_extension = opcache.so Also check .user.ini in your home directory.

    Can you check apache error logs at the end? ( https://www.siteground.com/kb/internal_server_error_500/ )

    Make simple phpinfo.php, open it and confirm that you don’t see “Zend OPcache” section (or it’s disabled)

    • This reply was modified 3 years, 5 months ago by Saša.

    @fandangointeractive,

    The problems seems to be Wordfence, yes. When I deactivate it and activate the others the site stops working properly.

    BTW, I got more sites on siteground running in PHP 7, with Yoast, Broken Link Checker and Wordfence and nothing happened.

    I had the same issue.. I switched back to PHP 5.6.29 and it seems to work now.
    I have Siteground as well. Maybe this helps

    @kevinmamaqi @stodorovic

    Just thought I’d let you know that a guy found a solution for this that only requires a couple of extra lines in php.ini.

    The solution is posted in this Facebook thread – https://www.facebook.com/groups/advancedwp/permalink/1365808633481347/ – and is as follows:

    The PHP variables manager [SiteGround] wouldn’t allow it [php.ini] to be modified so I dropped it in manually and seems to be working with these customisations [in php.ini]:

    opcache.interned_strings_buffer = 8
    opcache.memory_consumption = 256
    opcache.enable = On 
    

    I have tested this with the combination that caused so many issues before (Yoast + Wordfence + various plugins + PHP7 + SiteGround) and can confirm that everything now works 🙂

    Hi,

    I’ve got the same problem and I don’t think this is because of Yoast.
    I’ve 3 websites and only one that sometimes breaks with 500 error.

    I installed PHP compatibility checker https://wordpress.org/plugins/php-compatibility-checker/ to check PHP 7 compatibility with my plugins and it reveals some PHP errors but not about Yoast.

    educamia.com

    (@educamiacom)

    The following solution indeed works:
    customize [in php.ini]:

    opcache.interned_strings_buffer = 8
    opcache.memory_consumption = 256
    opcache.enable = On

    we are with siteground and keep having problems especially with cpu limit

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘FATAL ERROR: Allowed memory size of 805306368 bytes exhausted’ is closed to new replies.