Support » Fixing WordPress » Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate

  • Hi
    I know this subject has been covered elsewhere, but please bear with me. I get the following error when I try to add a new posting:-

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 15253304 bytes) in /home/content/c/h/a/charliewildish/html/wp-content/plugins/youtube-brackets/youtubebrackets.php on line 39

    I have a WordPress.Org blog hosted at Most “fixes” I’ve seen advise to go to “wp-config.php” (or similar) and amend the memory size. I have not be able to access “wp-config.php”. I just can’t get into it. Any advice would be greatly appreciated.
    Thanks Charlie

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Thanks Esmi, but unfortunately no joy.
    I’ve found my wp-config.php file on Godaddy (host). I’ve added code to define memory limit (none there before).
    I’ve gone into php.ini and added code there.
    I’ve added the plugin “memory bump”.
    I’ve upgraded to 3.0.1.
    None of worked. I tried turning off all plugins and upgrading again, still nothing.
    When I try to “preview” a new post, I still get:
    Fatal error: Out of memory (allocated 136052736) (tried to allocate 61013761 bytes) in /home/content/c/h/a/charliewildish/html/wp-content/plugins/youtube-brackets/youtubebrackets.php on line 37.

    I can’t find any htaccess files.
    I’ve contacted the host and I’m well within their limits.

    Any advice would be appreciated.

    PS: I don’t know if this will help or not, but the website is, if looking at it will give any clues.

    As per above, I seem to have tried everything apart from altering the .htaccess file. I’ve read that Godaddy (who is my host), often do not allow access to this file.
    Any advice on how I can get round this please.

    OK, I’ve managed to solve the problem and I thought I would share it in case anybody else has the same issue. After contacting Godaddy for the second time, I got the following response from them:

    “I understand you are having troubles with creating a post in WordPress on your hosting acount. I have reviewed the screenshot provided and the reason you are getting this error is because you are attempting to use more memory than is allowed on our shared hosting servers. This is usually due to a plugin that you may be using. You may want to try disabling all of your plugins and start enabling them 1 by 1 to try to pinpoint the problem plugin”.

    I tried this and found that the problem disappeared when I deactivated the plugin: “Youtube Brackets”.
    The only problem there is that my block heavily features Youtube videos, which could no longer be played.
    I therefore installed the plugin: “WP YouTube Player”.
    I had to go through each post individually to change the code, but now it all works and I’ve just added a new post. I’m hoping that this will be a permenant fix rather than a temporary one, but for now I’m up and running agian 🙂



    seems to be a lot of people who are having this problem are on GoDaddy, me too. Removing the plugins and even renaming the folder did not work for me. Contacted Godaddy they say everthings working fine on their end and got the standard sorry but they do not support third party apps (WP). thank you godaddy!

    I was using the BackWPup script that was giving me the “Allowed memory size of 67108864 bytes exhausted” error.

    I fixed the issue by doing the following. I followed the instructions on the following page to determine in which way I am using php:
    For me this was the “PHP Single php.ini” method.

    Then I followed the following instructions (with the changes detailed below):

    The corrections that I made were as follows:
    1. Placed the php.ini in the “public_html/” folder, not the “wp-includes/” folder.
    2. I used 96M as 64M was my current settings.
    3. I did not edit wp-settings.php as it appears to read the settings from wp-config.php
    4. I ran wp-config.php and tried to edit it and saw that it contained the line:
    define(‘WP_MEMORY_LIMIT’, ’96M’);
    (Maybe running wp-config.php was not necessary, I don’t know).

    Hope this helps.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate’ is closed to new replies.