Support » Plugin: WP eBay Product Feeds » Fatal error: Allowed memory size of 67108864 bytes exhausted

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Rhys Wynne

    (@rhyswynne)

    Hi There,

    My guess is the hosting. Who are you hosted with? You can speak to them see if they can increase your memory on the server.

    You are also showing 200 items. The one that is working is showing 50 items so maybe that’s why it works. 200 items is quite a lot. Does it fail when you so less items?

    Thanks

    Rhys

    Thread Starter tasaadi

    (@tasaadi)

    Hi Rhys,

    Hosting is with Godaddy. I have reduced the failing page to show 10 items and it still fails with the same error. I have tried from another browser and another machine to make sure that nothing is cached – without changing the error.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 359144 bytes) in /home/content/21/12122721/html/wp-includes/wp-db.php on line 3116.

    So that doesn’t’t seem to be the solution.

    Thx

    Trevor

    Plugin Author Rhys Wynne

    (@rhyswynne)

    Hi Trevor,

    Is there any other caching? Like server caching?

    Could you try running without anything but eBay Feeds for WordPress?

    Could you speak with GoDaddy to see if they have any ideas?

    Rhys

    Thread Starter tasaadi

    (@tasaadi)

    Hi Rhys,

    If I use the following link

    [ebayfeedsforwordpress feed=”http://rest.ebay.com/epn/v1/find/item.rss?keyword=Govancroft&categoryId1=870&sortOrder=BestMatch&programid=15&campaignid=5337448158&toolid=10039&listingType1=All&lgeo=1&descriptionSearch=false&feedType=rss” items=”200″]

    I get memory failure. From the same search directly on eBay I get 81 hits.

    If I make a simple change the search to add Stoneware – as follows

    [ebayfeedsforwordpress feed=”http://rest.ebay.com/epn/v1/find/item.rss?keyword=Govancroft Stoneware&categoryId1=870&sortOrder=BestMatch&programid=15&campaignid=5337448158&toolid=10039&listingType1=All&lgeo=1&descriptionSearch=false&feedType=rss” items=”200″]

    I get a sensible listing display. This returns 34 items.

    I have tried this with several combinations and it would seem that any search that has more than about 50 results causes the error. Less than 50 and its ok. Setting the number of “items” to be any value does not seem to impact the error. So reducing from 200 to 10 does not change anything. It would seem that the memory error is driven by the potential number of results – not by what is asked to be shown.

    Are there any changes on the eBay side (e.g. photo quality) that impact on the memory needed to capture items?

    Thx

    Trevor

    Plugin Author Rhys Wynne

    (@rhyswynne)

    Could you disable the feed caching? See if that helps?

    It does seem strange that your host doesn’t seem to be able to handle your feed. A feed with 80-odd items shouldn’t cause memory issues.

    Thread Starter tasaadi

    (@tasaadi)

    Hi Rhys,

    I have been though Godaddy files on the site, I have also installed Wordfence protection on the site and run a scan. It picked up some incompatible plugins – which I have removed – and corrected anything it found.

    Everything now seems to be working – but don’t know why the changes I have done would cause it to work – although I didn’t retest before I installed wordfence – so can’t be sure that it wasn’t working before installation.

    However, things are back to normal and working well again.

    Many thanks for your support and hope everything goes back to the usual flawless performance.

    Please mark this as closed.

    Plugin Author Rhys Wynne

    (@rhyswynne)

    Hi Trevor,

    Good to hear. Strange issue, and would love to know what was causing the issue. Be interested to know what the plugins that you removed, so I can possibly help people further down the line if they have a similar setup.

    Thanks again, and for the review too!

    Rhys

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal error: Allowed memory size of 67108864 bytes exhausted’ is closed to new replies.