Support » Plugin: MarketPress - WordPress eCommerce » Fatal error: Allowed memory size of 33554432 bytes exhausted

  • Resolved sounds

    (@sounds)



    Hi,

    When I install the plugin inside wordpress I get an error about memory,
    So I downloaded and installed the plugin but still get the error message below..

    Installing Plugin from uploaded file: wordpress-ecommerce.zip
    Unpacking the packageā€¦

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 595444 bytes) in /home/dyt/public_html/main/wp-admin/includes/file.php on line 707

    I looked in cpanel > wordpress root, the php.ini is set to 64mb,
    I looked in whm / cpanel and the memory limit is set to 512mb.

    I’m hoping I can set this up to allow members to sell their own music from our wp site.

    Any help appreciated,

    Thanks,
    EMar

    • This topic was modified 1 year, 9 months ago by  sounds.
Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Support Nastia – WPMU DEV Support

    (@wpmudev-support9)

    Hello @sounds,

    Hope you’re well!

    Please try increasing the PHP memory of the root site, replace this line in php.ini:
    ini_set( 'memory_limit', '64M' );
    to
    ini_set( 'memory_limit', '256M' );

    Let me know how it went!

    Cheers,
    Nastia

    Nastia,

    The php.ini inside the wordpress root looks different.

    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    max_input_vars = 1000
    memory_limit = 64M ; Maximum amount of memory a script may consume (32MB)

    Thanks

    • This reply was modified 1 year, 9 months ago by  sounds.

    Same warning,

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 49152 bytes) in /home/site/public_html/main/wp-content/plugins/wordpress-ecommerce/includes/common/shipping-modules/mp-usps.php on line 641

    The memory limit is set to 512 inside whm/cpanel > PHP Configuration Editor.
    I also set it to 256 in the wordpress root php.ini.

    Same error if I upload the plugin zip and install it

    Unpacking the packageā€¦

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 392308 bytes) in /home/site/public_html/main/wp-admin/includes/file.php on line 707

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello sounds,

    Could you check if you are able to upload and install plugin when other plugins are disabled?
    If yes, let me know if this time you will be able to install MarketPress.

    kind regards,
    Kasia

    Hi,

    Just tried that, disabled all plugins and uploaded marketpress,
    It said installed successfully but gave error when teying to enable

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 12288 bytes) in /home/site/public_html/main/wp-admin/includes/deprecated.php on line 535

    I’m gonna try install it from wp plugin section.

    Same error if I install inside wordpress, all plugins disabled.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 12288 bytes) in /home/site/public_html/main/wp-admin/admin-header.php on line 40

    I’m able to install it but can’t activate without error, once installed,
    I had a look in phpmyadmin at the db tables, there’s nothing for marketpress in there.

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    Hello sounds,

    Huh. That is strange. Can you try increasing to 512 in the wordpress root php.ini? Can you also tell me what is PHP version on your hosting and who is your hosting provider?

    kind regards,
    Kasia

    cPanel PHP Version 5.4.45, It’s hosted on our own server.
    Accessing cPanel, I goto public_html > wpfolder > php.ini

    ;;;;;;;;;;;;;;;;;;;
    ; Resource Limits ;
    ;;;;;;;;;;;;;;;;;;;

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    max_input_vars = 1000
    memory_limit = 512M ; Maximum amount of memory a script may consume (32MB)

    Save, back to wordpress, disable all plugins,
    Back to plugins, click add new, search marketpress, install it.
    And here comes the scary part.. click activate…

    This error message can vary: https://snag.gy/BHIbS1.jpg

    I then tried the upload option, got it from here:
    https://wordpress.org/plugins/wordpress-ecommerce/

    Same error message after activating.

    • This reply was modified 1 year, 9 months ago by  sounds.

    Upgraded server php version to ea-php70
    The default PHP version has been set to 7.0.16

    Will try again and let you know.

    Plugin Support Kasia – WPMU DEV Support

    (@wpmudev-support2)

    hello sounds,

    How it went? Was there any success this time?

    kind regards,
    Kasia

    Hi,

    No I couldn’t activated it without those errors.

    Plugin Support Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @sounds,

    Could you create new info.php file inside your WP root folder and add this code in that file:
    <?php phpinfo(); ?>
    Save the file and now visit yourdomain.com/info.php where you will find your PHP details, check what Memory limit value is in there so we can see if the changes you are making are taking effect.

    Please remove that file once done.

    Cheers,
    Predrag

    Ok I’m on it…

    Damn it says 32m, I changed this already in the wp root php.ini
    I also logged into the server whm/cpanel and updated it there.
    I’ll have to check again, maybe I’m in the wrong location.

    max_execution_time = 30 ; Maximum execution time of each script, in seconds
    max_input_time = 60 ; Maximum amount of time each script may spend parsing request data
    max_input_vars = 1000
    memory_limit = 256M ; Maximum amount of memory a script may consume (32MB)

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Fatal error: Allowed memory size of 33554432 bytes exhausted’ is closed to new replies.