Support » Fixing WordPress » Fatal error: Allowed memory size of 33554432 bytes exhausted

  • Resolved harry216921

    (@harry216921)


    New install of wordpress with Crazydomains….

    Was getting this error when trying to upload a 260kb pic through a post:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 15552 bytes) in /home/mydomain/public_html/blog_wp/wp-includes/media.php on line 253

    So, I finally gave up on this method (since I can’t edit anything to do with my php.ini) and decided to try a plugin “Add from Server”.

    I uploaded a larger pic 3mb, to a directory in my install, then tried importing with the plugin…. EXACTLY the SAME ERROR!

    Does anybody have any ideas?

Viewing 2 replies - 31 through 32 (of 32 total)
  • I’m with Crazydomains too, been trying all day and night to fix my Fatal Error and I still get it.

    Changed config.php, added php.ini in the wp-admin folder to 128M and still get error 🙁

    http://www.bernardlau.com.au

    Got a feeling it’s the host that’s not allowing memory to go beyond 32mb… waiting to hear back from them.

    Great! the setting worked for me (http://www.readforgreed.com) too:
    memory_limit = 256M ;
    upload_max_filesize = 10M
    post_max_size = 10M

    I got the error after implementing the buddy press.
    Now even I edit 10=20 to get more upload limit and its also worked.
    Thanks everyone..

Viewing 2 replies - 31 through 32 (of 32 total)
  • The topic ‘Fatal error: Allowed memory size of 33554432 bytes exhausted’ is closed to new replies.