Support » Plugin: Wordfence Security - Firewall & Malware Scan » Fatal error: Allowed memory size of

  • Resolved jviseur

    (@jviseur)


    Hi,

    I am getting the error below when scanning site.

    [Apr 18 21:28:35] Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 40960 bytes) in /home/viseu487/public_html/cccnz.club/wp-content/plugins/wordfence/lib/wordfenceHash.php on line 710

    I have increased the memory_limit in PHP to 256M. This may have fixed the issue but now scan stops (see lines below)

    [Apr 18 21:50:36] Contacting Wordfence to initiate scan
    [Apr 18 21:50:37] Starting DNS scan for cccnz.club
    [Apr 18 21:50:37] Scanning DNS A record for cccnz.club
    [Apr 18 21:50:37] Scanning DNS MX record for cccnz.club
    [Apr 18 21:50:37] Total disk space: 49.09 GB — Free disk space: 26.56 GB
    [Apr 18 21:50:37] The disk has 27195.75 MB available
    [Apr 18 21:50:37] Getting plugin list from WordPress
    [Apr 18 21:50:37] Found 52 plugins
    [Apr 18 21:50:37] Getting theme list from WordPress
    [Apr 18 21:50:37] Found 3 themes
    [Apr 18 21:50:38] 500 files indexed
    [Apr 18 21:50:38] 1000 files indexed
    [Apr 18 21:50:39] 1500 files indexed
    [Apr 18 21:50:39] 2000 files indexed
    [Apr 18 21:50:39] 2500 files indexed
    [Apr 18 21:50:39] 3000 files indexed
    [Apr 18 21:50:39] 3500 files indexed
    [Apr 18 21:50:39] 4000 files indexed

Viewing 4 replies - 1 through 4 (of 4 total)
  • jviseur

    (@jviseur)

    Sorry I forgot to request if someone is able to assist with this issue.

    Plugin Support wfphil

    (@wfphil)

    Hi @jviseur,

    Can you do the following so I can get the information I need to help you:

    – Kill the existing scan if one is still running by pressing the STOP SCAN button.

    – Click on the Scan Options and Scheduling link.

    – In the Performance Options section set Maximum execution time for each scan stage to 20. (This may actually fix the issue).

    – Hit the SAVE CHANGES button.

    – Go to the bottom of the Diagnostics tab on the Tools page and expand the Debugging Options section. Enable the option Enable debugging mode (increases database load).

    – Hit the SAVE CHANGES button.

    – Start a new scan.

    – If the scan fails with a message saying that the scan has failed, stop the scan and click on the SHOW LOG link and copy the most recent 20 or so lines of the scan activity log and paste in a reply here.

    Also, I would like to have a look at your Wordfence diagnostics report. Please go to the top of the Diagnostics tab on the Wordfence Tools page. There will be a SEND REPORT BY EMAIL button to send the diagnostics report. Enter wftest@wordfence.com as the email and @jviseur as the forum user please.

    Thank you.

    Thank you @wfphil I have emailed the requested details.

    Also I noticed that when I went back into Wordfence Scan it was sitting at 9000 instead of the reported 4000.

    Plugin Support wfphil

    (@wfphil)

    Hi @jviseur

    I see that you have changed the wrong setting.

    You set the option Time limit that a scan can run in seconds to 20 instead of the option Maximum execution time for each scan stage

    – Set the option Time limit that a scan can run in seconds to a blank value.

    – Set the option Maximum execution time for each scan stage to a value of 20

    Remember to save the changes.

    – Go to the bottom of the Diagnostics tab on the Tools page and expand the Debugging Options section. Enable the option Enable debugging mode (increases database load).

    – Hit the SAVE CHANGES button.

    – Start a new scan.

    – If the scan fails with a message saying that the scan has failed, stop the scan and click on the VIEW FULL LOG link and copy the most recent 20 or so lines of the scan activity log and paste in a reply here.

    Also, I haven’t received your Wordfence diagnostics report. Please go to the top of the Diagnostics tab on the Wordfence Tools page. There will be a SEND REPORT BY EMAIL button to send the diagnostics report. Enter wftest@wordfence.com as the email and @jviseur as the forum user please.

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.