Support » Installing WordPress » Fatal error: Allowed memory size of ..

  • Resolved alicetragedy


    Hello everyone!
    I hope someone out there can help me…

    SO. I have just changed web servers.
    I have backed up my databases, tables, etc.. before switching.
    I am now trying to install wordpress again, but it doesn’t seem to work!

    first off, on this new server, it won’t let me choose my own database name, so instead of something simple like “blog” I have “usr_web238_1” – but that, I guess, is beyond the point. Anyway, phpmyadmin will accept my .sql backup into my new database “usr_web238_1”, I have uploaded all my wordpress files (the basic installation, not my posts, etc..) to my /blog folder, have changed the username and password of my wp-config.php file…… but when I try to access my wp-admin/index.php it tells me:

    “Your database is out-of-date. Please upgrade.”

    so when I go to upgrade.php, I get the following message:

    “Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 143 bytes) in /home/www/web238/html/blog/wp-admin/admin-functions.php on line 1618”

    I don’t know what’s going on, I have tried setting up different databases, uploading and deleting things left and right, changing passwords, installing wordpress again and again, but nothing will work! the install.php file won’t run either. I don’t know what to do. please help! I need my wordpress fix!!!! 🙁

    ps: my url is,
    wordpress is located at /blog


Viewing 4 replies - 1 through 4 (of 4 total)
  • If allowed by host, bump the php memory to 32M – or ask host to do it.

    thanks. will do that and then let you know if it worked.

    it’s up! lovely!

    thank you sooooo much. I’m happy^^

    Here’s what worked for me, similar to what others have recommended:

    add to wp-config.php:

    define('WP_MEMORY_LIMIT', '64M');

    I wish I knew what caused the problem initially… suddenly I couldn’t access my backend (wp-admin)… and got the error about allowed memory size exhausted… I disabled some plugins and was able to access the backend. I then renabled plugins except for any that I could live without. However, I was still seeing the message in certain places like in the Dashboard under “wordpress development blog” and “Other WordPress News”… instead of showing the feed data it was just showing the memory error within those boxes. This fix made those errors go away.

    Now I just wonder if there’s a way to optimize what I am using to not go over the 32M default limit? Or is there some other error that it’s causing it to go over the 32M limit and what I’ve done is simply applying a band-aid by raising the limit to 64M?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal error: Allowed memory size of ..’ is closed to new replies.