Support » Themes and Templates » Fatal error: Allowed memory size exhausted – Help

  • am1am2


    When we changed the settings in MyMag Options, instead of saving them they stayed the same and we got this error message:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8390103 bytes) in /home/mornin26/public_html/wp-includes/wp-db.php on line 849.

    Other times, it says the changes are saved, but they stay the same anyway.

    I have got my host server to create symbolic links to all folders in my public_html directory and increase memory limit to 256M.

    But we are still having the same problem.

    Does anyone know why this might be happening and what we can do about it?

Viewing 11 replies - 1 through 11 (of 11 total)
  • am1am2


    Can anyone help us urgently with this problem?

    It has been 18 hours and no response.

    Thank you.

    I’ve got the same problem. I using wp version 3.0.1
    There are so many questions in this forum regarding this problem, a lot of people seem to be able to sort it out, but none of the suggestions are working for me. I’m trying to work with plugins.

    I’m wondering if there is a limit to the number of plugins that you can have in wp.
    To get around this error message I have been doing all my updates manually using ftp.
    However I don’t seem to able to install more than 5 plugins, because that’s what caused this recent memory loss. or else it was the actual plug in.
    I just deleted the last plug in that I uploaded and that fixed the error message.

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '128M');
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 128M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 128M
    4. Talk to your host.

    thanks for your prompt reply Samuel.
    I have tried all that, even spoken to my host who told me where and how to do it myself.

    i’m thinking there must be something missing in my code because I’m not familiar with php but I’ve looked it up … i found out that php.ini is actually a php file so it needs php opening and closing tags. My host told me to make my own file and put it in the folder which houses the upload script … i’m guessing that would be the plugin folder.

    We’re still having this same problem on our site.

    I’m thinking it has nothing to do with the memory and there is some kind of glitch in the programming.

    Do you know anyway I can go into the actual files through my server host and update the myMag settings for different categories, slideshow, etc?

    Hi am1am2,
    I was using ftp to upload new versions of wp and plugins … but that’s not working anymore. And now there is no memory to process uploaded images. And I don’t have much on my site yet.
    Interesting that you think it’s a programing glitch. I have certainly not seen anything like it before, and so many people have the same problem … but they seem to have solved it.

    my wonderful hosts at Planet Domain fixed it and have given me 300mb. Now all works.
    Instructions given so often in posts are right, the .htaccess file and the php.ini and they have to be at the top level. I had them in the uploads folder, and/or in the plugins folder, and when I tried them at the top level, I no doubt had something wrong with the code.

    Hi, I have the same error. It happens in wp-db.php on line 849 and on line 787. It appeared out of the blue.
    I tried everything: My host told me to create a php.ini, I did so and checked it with phpinfo(). I also edited the wpconfig.php.
    Editing the htaccess file gave me an 500 server error.

    I still get the error. It appears when I try to change the permalink structure, when I update a page (no problems with posts) although the changes appeal. But it is impossible to create a new page.

    Is there any other way to fix this problem?

    I found this article helpful.
    Seems like it was the language package that caused the problems. Now everything works fine. ^^

    Simple fix that might not be a long term fix is commenting out line 849. Not sure if it’s a security problem commenting it out but my site is working now. Hope that helps temporarily.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Fatal error: Allowed memory size exhausted – Help’ is closed to new replies.