Support » Plugin: BulletProof Security » Fatal error: Allowed memory size exhausted

  • Resolved SRD75


    I receive notices from BPS:

    BPS Alert! Your site does not appear to be protected by BulletProof Security

    BPS Alert! An htaccess file was NOT found in your wp-admin folder. Check the BPS Security Status page for more specific information.

    When I go to the Security Status page, I receive an error:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /…/wp-content/plugins/bulletproof-security/admin/options.php on line 1649

    and no other content is showing in the content pane (just WordPress admin is showing).

    How do I resolve this please?


Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author AITpro


    Which web host do you have?

    FTP to your website and delete the .htaccess file in your website root folder.

    Then go to the BPS System Info page and post this information about your website.

    DNS Name Server:
    Server Type:
    Operating System:
    Server API:

    I’m not sure what host the website uses.

    If I delete .htaccess in the web root, I can’t login to wp-admin to get the information.

    I think .htaccess is required for wp-admin, isn’t it?

    Plugin Author AITpro


    Normally you should be able to login without an .htaccess file in your root folder so I am not sure why you cannot login.

    Upload a standard WordPress .htaccess file to your website.

    You’re right. I had just renamed the database table prefix (for security reasons) without updating meta key names, which prevented me from logging in.

    Now I have renamed .htacess, and gone to the main BPS options page, but I receive:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /…/wp-content/plugins/bulletproof-security/admin/options.php on line 1649

    The side menu is not flying out with any BPS subpages.

    What is the URL of the BPS system info page so I can go there directly?




    Forum Moderator

    This is a site issue rather than a plugin-specific one. Try increasing the memory available to PHP.

    Ok. All of those suggestions failed.

    I’ll ask the web host to see if they can increase the limit.

    Plugin Author AITpro


    Yep, esmi is absolutely correct since the allowed memory size is only 32M for this website (I completely missed that ;). WordPress itself needs a base amount of memory to do what it needs to do and 32M is a ridiculously small amount of allocated memory. The bare minimum memory for any WordPress site should be 64M and ideally 256M is an optimum amount of allocated memory.

    What is actually happening around code line 1649 in the options.php file is System Info checks – Folder/directory path checks, IP Address Checks, DNS info checks, etc. I have seen on a couple of Host’s where the Host is restricting something with DNS and this causes an error on the System Info page, but this would not cause an “out of memory” error directly. So logically it just so happens that you are running out of memory at this particular point in script processing.

    The web host increased the memory to 64MB and the original error message is gone.

    Thanks for all of your assistance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Fatal error: Allowed memory size exhausted’ is closed to new replies.