Support » Plugin: iThemes Security (formerly Better WP Security) » Fatal error: Allowed memory size …

  • I have just updated this security plugin on my site and now my events calendar is throwing this error:

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 6994 bytes) in /home/xxxxxx/public_html/wp-content/plugins/the-events-calendar/views/month/single-event.php on line 186″

    I’ve isolated the problem to be this security plugin. Can anyone help me troubleshoot this problem?

    https://wordpress.org/plugins/better-wp-security/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Do you get the memory error on the frontend website or in WP Dashboard (backend) or perhaps both ?

    dwinden

    It’s on the front-end. Here’s the page where you can see it occurring: http://www.theartistsgallery.com/events/category/member-shows/

    Hmmm … it seems to be working just fine all the way here in Holland using either Mozilla Firefox 36.0.1 or MS Internet Explorer 11.0 from a Windows 7 SP1 client.

    Are you still having the memory error on that page ?

    Anyway, login to the WP Dashboard and make sure that the “Enable Scheduled Database Backups” checkbox is disabled in the Database Backups section of the iTSec plugin Settings page.

    Even though Scheduled Backups are scheduled they are kicked off (once the next scheduled date\time is passed) by users just visiting the website.
    Might have had some incidental effect … though it doesn’t explain why the issue started after updating the iTSec plugin.
    But iTSec plugin Scheduled Backups are known to cause memory issues under certain conditions …

    Do you remember from what version the iTSec plugin update took place ?

    It seems the PHP memory_limit on your server is set to 32 MB.
    As 32 < 40 WordPress will set the frontend PHP memory_limit to 40 MB.

    Should the memory error frequently reoccur then you could try and increase available PHP memory for the frontend by adding the following line to the wp-config.php file:

    define(‘WP_MEMORY_LIMIT’, ’64M’);

    Basically increase it to any value > 40 MB.

    dwinden

    Interesting. It doesn’t happen in IE11 or Firefox’s 35.0.1. from a Windows 8 client and on Mac OSX. In either client, it fails in Chrome. Unfortunately I don’t remember the version I upgraded from so can’t help there.

    Checked the plugin and I don’t have backups enabled. I just added the memory code to the config file. Tried 64M – no change. Tried 128M – no change.

    I may have to go to the events plugin support next to see if they have any ideas.

    Thank you for the excellent information re: backup and memory problems. I’l keep pursing.

    Ok, I think I have it. I removed the File Change check and that seems to resolve the memory error. Not sure why that feature is so resource intensive but it’s resolved for me at the moment.

    Thanks, dwinden, for all your tips and clues. It lead me to the solution!

    Ah, the thought crossed my mind …

    Yep, “File Change Detection” is in second place when it comes to iTSec plugin features that may require a lot of memory.
    And it works just like Scheduled Backups. Kicked off by a user visiting the website after the next scheduled date\time has passed.

    You can actually see how much memory a (successfull\completed) “File Change Detection” scan used by going to the iTSec plugin Logs page and selecting “File Change History” from the Select Filter dropdown list.

    I’m a little bit concerned about the fact that the issue also seems to be browser dependant … that is not a good sign.

    Still great you were able to pinpoint the problem en therefore find a solution.

    Oh there is one question I am really interested in being answered.
    When you changed the WP_MEMORY_LIMIT in wp-config.php you are saying there was “no change”. So it still produced a memory error in Google Chrome. Did it also still mention the 41943040 bytes memory threshhold ?
    Or did that threshhold change according to the value set for WP_MEMORY_LIMIT (for 64M it would probably have been something like 67108864 bytes).

    Ideally you would like to keep using the “File Change Detection” feature (for security reasons) and raising the WP_MEMORY_LIMIT value should enable you to do that.
    If the answer to my question is No perhaps you did not set it correctly in wp-config.php. Just a thought.

    dwinden

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error: Allowed memory size …’ is closed to new replies.