Support » Fixing WordPress » Fatal error: Allowed memory size…

  • Resolved wb19


    This is in relation to all the other comments about having issues with Allowed memory size. Except this current version is 3.0.3 not 2.8.x.

    I’ve tried adding define('WP_MEMORY_LIMIT', '256M' ); to the wp-config.php file correctly and deactivating plugins one by one.

    I’ve had some luck in upgrading plugins but not entirely 100%.
    I’m trying to upgrade to 3.0.5 but I still keep getting the Fatal error listed below, however sometimes it’s not class-simplepie.php but sometimes it’s wp-db.php that shows up instead.

    I do not have access to the php.ini file.

    The following is listed on, WordPress Blog, Incoming Links and Plugins within the Dashboard.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 92160 bytes) in /httpdocs/wp-includes/class-simplepie.php on line 14907

Viewing 13 replies - 1 through 13 (of 13 total)
  • Moderator t-p


    I tried, as stated in my post above. I started out with adding it to the wp-config.php file, then increased from 64 to 96 to 256M. Same issue.

    Moderator t-p


    -try deactivating all plugins before updating.

    All Plugins deactivated still cannot upgrade do to same issue.

    It appears that Akismet was the plugin causing the error messages to appear on the Dashboard. However when trying to update using the automated update tool the error message would then appear on the update screen. But this was if ALL plugins were deactivated.

    Moderator t-p




    Forum Moderator

    Try asking your hosts for assistance.

    t-p, I’m working on manually updating now. I really don’t want to give in, this has never been an issue for me in the multiple sites I work with.

    P.s. I updated my comment above (edit)

    I’m having the same issue, trying to upgrade from 3.0.3 to 3.0.5. I managed to upgrade all the plug-ins (some had to be deleted and re-installed to get the latest versions), but still can’t upgrade WordPress. In re-reading the docs, I’m not sure the upgrade is really that significant, as I’m not having any problems. Certainly doesn’t appear to be worth the problem of a manual upgrade, considering the research I’d have to do so as not to lose everything I’ve already got. Would you agree?

    Moderator t-p


    @eightwheels before updating, try deactivating ALL plugins.

    A few things to update:
    All Plugins deactivated, cache deleted, upgraded wordpress manually via instructions to the T.

    But after upgrading I receive this fatal error when trying to access the Dashboard after logging in as admin. All I get is a white page with this message:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 23040 bytes) in /httpdocs/wp-admin/includes/template.php on line 1510

    So I went back to 3.0.3 and it’s the same fatal error.
    I replaced exactly the same files that I replaced when going from 3.0.3 to 3.0.5 then back to 3.0.3

    Anything else I can try?
    I have total access to my Virtuozzo server, which means I am my host. 🙂

    Moderator t-p


    -If the above steps do not resolve the issue, Download WordPress again and replace your copies of everything EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies. This should replace your core files without changing your content and settings in wp-config.php file and the /wp-content/ directory.

    -if that does not resolve the issue, contact your host.

    Ok, well, as stated, that was done, three times, and still the fatal error is there. But unfortunately after doing that the fatal error evolved and didn’t allow us to log into the dashboard to edit posts, pages, etc.,

    Also as stated, we are our own hosts, but again for us, it’s an unfortunate issue of our host admin decided to have a nervous breakdown and won’t be helping us on the host side anymore.

    Thankfully I know a little about it, but enough to say the database is corrupted and we just decided to do a complete fresh install of the latest version instead of trying to fix 3.0.3.

    I find it odd that a lot of people are having the same issues and are being told to do the same thing but are still having the same issues after doing the suggestions.

    Maybe WordPress 3.1 will fix a lot of these complaints many folks are having. Other than that, a fresh install works the way it should… except sending email to newly registered users… this happens more so than the memory issues.

    So, I’m closing this discussion as being resolved, even though it’ll probably never get resolved.

    Good luck my fellow WordPress users that need help!

    @t-p — I wasn’t optimistic, since I’ve read so many instances of deactivating all plugins not making any difference. But, in my case, it worked! I’m now running 3.0.5 with no issues so far. All plugins updated now, too. Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Fatal error: Allowed memory size…’ is closed to new replies.