Support » Plugin: Yoast SEO » Fatal error after Yoastseo update

  • Resolved arthurki1

    (@arthurki1)


    Hey,

    I updated the yoastseo plugin today and when I try to open my dashboard I get this Error message:

    Warning: include(/var/www/web24493669/html/blubberwp/wp-content/plugins/wordpress-seo/inc/sitemaps/class-sitemap-timezone.php): failed to open stream: No such file or directory in /var/www/web24493669/html/blubberwp/wp-content/plugins/woocommerce-admin/vendor/composer/ClassLoader.php on line 444

    Fatal error: Uncaught Error: Class ‘WPSEO_Health_Check_Page_Comments’ not found in /var/www/web24493669/html/blubberwp/wp-content/plugins/wordpress-seo/admin/class-admin-init.php:50 Stack trace: #0 /var/www/web24493669/html/blubberwp/wp-content/plugins/wordpress-seo/wp-seo-main.php(412): WPSEO_Admin_Init->__construct() #1 /var/www/web24493669/html/blubberwp/wp-includes/class-wp-hook.php(288): wpseo_admin_init(”) #2 /var/www/web24493669/html/blubberwp/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #3 /var/www/web24493669/html/blubberwp/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #4 /var/www/web24493669/html/blubberwp/wp-settings.php(392): do_action(‘plugins_loaded’) #5 /var/www/web24493669/html/blubberwp/wp-config.php(102): require_once(‘/var/www/web244…’) #6 /var/www/web24493669/html/blubberwp/wp-load.php(37): require_once(‘/var/www/web244…’) #7 /var/www/web24493669/html/blubberwp/wp-admin/admin.php(34): require_once(‘/var/www/web244…’) #8 /var/www/web24493669/html/blubberwp/wp-a in /var/www/web24493669/html/blubberwp/wp-content/plugins/wordpress-seo/admin/class-admin-init.php on line 50

    When I deactivate the plugin everything works as it should. Any idea how I can fix this?

    My is PHP-Version: 5.6.40

    • This topic was modified 7 months, 1 week ago by arthurki1.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Getting same error with new version with PHP 7.3.x as well.

    Hi,

    Have problem also, website is hosted with Hostinger.

    I installed the older Pluginversion to fix the problem for now. Here’s a guide if anyone needs it: https://kinsta.com/knowledgebase/download-older-versions-of-wordpress-plugins/

    Plugin Support Pcosta88

    (@pcosta88)

    @arthurki1

    This issue occurs when the plugin installation or update couldn’t complete correctly. The fatal error is telling you that the plugin couldn’t find one of the cores Yoast SEO plugin files. In this case, can you please reinstall it manually using File Transfer Protocol (FTP) to see if this resolves the issue? 

    You can learn more about how to update manually using FTP here: https://kb.yoast.com/kb/how-can-i-update-my-premium-plugin/. You will need an FTP program such as FileZilla and your FTP details, which can be obtained from your host provider. 

    Note, that when you install via FTP you are not expect to lose your data or SEO settings, even if prompted to overwrite the existing files. All your data will be saved and will appear and work after manually installing Yoast. 

    @pierreto @fropki

    If you are still experiencing the issue per the forum guidelines, we ask that you please create separate topics for the issues you are experiencing. That way it’s easier to track issues and provide assistance on your specific concerns on your specific site. Plus, you will get your own alerts for the issue rather than someone else’s. You may make a new topic here: https://wordpress.org/support/plugin/wordpress-seo/#new-post. Thanks!

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to lack of activity by original poster.

    If you are not the original poster but have a similar issue, please open a new request.

    This problem is not solved in the latest version of Yoast (12.9.1).
    Downgrading to 12.9 and uploading the plugin over FTP (we should be very ashamed to do this!), with root access solved the problem.

    • This reply was modified 6 months, 2 weeks ago by mikevdberg.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error after Yoastseo update’ is closed to new replies.