Support » Plugin: WPSEO Pinterest Rich Pins for WooCommerce » Fatal error after Yoast SEO update (>7.03)

  • Hello,

    unfortuantely there is a fatal error after last updates of YOAST SEO. The problem starts from version 7.1, last working version is 7.03. Hope you are able to fix this. Attaching the information:

    Fatal error: Uncaught Error: Call to a member function remove_hooks() on null in /alt/home/webmaster.napogloves/www/html/us/wp-content/plugins/wordpress-seo/inc/options/class-wpseo-options.php:228 Stack trace: #0 /alt/home/webmaster.napogloves/www/html/us/wp-content/plugins/wordpress-seo/admin/metabox/class-metabox.php(44): WPSEO_Options::get(‘opengraph’, false) #1 /alt/home/webmaster.napogloves/www/html/us/wp-content/plugins/wpseo-pinterest-rich-pins-for-woocommerce/wpseo-pinterest-rich-pins-woocommerce.php(74): WPSEO_Metabox->__construct() #2 /alt/home/webmaster.napogloves/www/html/us/wp-includes/class-wp-hook.php(286): WPSEO_Pinterest_Rich_Pins->set_meta_box(”) #3 /alt/home/webmaster.napogloves/www/html/us/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /alt/home/webmaster.napogloves/www/html/us/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /alt/home/webmaster.napogloves/www/html/us/wp-settings.php(327): do_action(‘plugins_loaded’) #6 /alt/home/webmaster.napogloves/www/html/us/wp-config.php(90): require_once(‘/alt/home/webma…’) #7 /alt/home/webmaster.napogloves/www/html/us/wp-load.php(37): require_once(‘/alt/home/webma…’) #8 /alt/home/webmaster.napogloves/www/html/us/wp-admin/admin.php(31): require_once(‘/alt/home/webma…’) #9 /alt/home/webmaster.napogloves/www/html/us/wp-admin/plugins.php(10): require_once(‘/alt/home/webma…’) #10 {main} thrown in /alt/home/webmaster.napogloves/www/html/us/wp-content/plugins/wordpress-seo/inc/options/class-wpseo-options.php on line 228

Viewing 2 replies - 1 through 2 (of 2 total)
  • The error I experienced was Fatal error: Call to a member function remove_hooks() on null in /wp-content/plugins/wordpress-seo/inc/options/class-wpseo-options.php on line 228.

    I deactivated all plugins except for Yoast and then began reactivating one by one. Turns out this was caused by WPSEO Pinterest Rich Pins for WooCommerce for me, which is a very old plugin that hasn’t been updated in some time. I removed that plugin and Yoast now works fine, although I haven’t found a suitable substitute.

    Same issue here, managed to fix it by disabling WPSEO Pinterest Rich Pins for WooCommerce. Unfortunately not alternative for this plugin and failed at trying to contact the author.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Fatal error after Yoast SEO update (>7.03)’ is closed to new replies.