Support » Plugin: Yoast SEO » Fatal Error after Yoast 14.0 update

  • Resolved anupamasam

    (@anupamasam)


    Hi,

    Updated the Yoast to 14 and got a fatal error while accessing the webpages.eg: https://www.staffordglobal.org/university-courses/mba-degree/part-time-mba-courses/

    Fatalerror:UncaughtException:invalid_termin/home/staffo65/public_html/wp­
    contenVplugins/wordpress-seo/src/builders/indexable-term-builder.php:53 Stack trace: #0
    /home/staffo65/publ ic_html/wp-content/plugins/wordpress-seo/src/bu i lders/i ndexable­builder.php(164):Yoast\WP\SEO\Builders\Indexable_Term_Builder->buiId(”,
    Object(Yoast\WP\SEO\Models\lndexable)) #1/home/staffo65/public_html/wp­contenVplugins/wordpress-seo/src/repositories/i ndexable-repository.php(289):Yoast\WP\SEO\Builders\lndexable_Builder->build_for_id_and_type(”,’term’)#2
    /home/staffo65/publ ic_html/wp-content/plugins/wordpress-seo/src/repositories/indexable­repository.php(99):Yoast\WP\SEO\Repositories\lndexable_Repository->find_by_id_and_type(‘•,’term’) #3/home/staffo65/public_html/wp-content/plugins/wordpress-seo/src/memoizers/meta­tags-context-memoizer.php(94):Yoast\WP\SEO\Repositories\lndexable_Repository-
    >for_current_pageO #4 /home/staffo65/public_html/wp-content/plugins/wordpress­seo/src/integrations/front-end-integration.php(254):Yoast in /home/staffo65/public_html/wp­content/plugins/wordpress-seo/src/builders/indexable-term-builder.php on line 53

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author Joost de Valk

    (@joostdevalk)

    Hi @anupamasam,

    sorry to hear this. We’re looking into what’s causing this!

    Same here. Wish you good fortune solving this.

    same here…
    Error Details
    =============
    An error of type E_ERROR was caused in line 19 of the file /home/domain/public_html/wp-content/plugins/wordpress-seo-premium/inc/wpseo-functions.php. Error message: Uncaught Error: Class ‘WPSEO_Frontend’ not found in /home/domain/public_html/wp-content/plugins/wordpress-seo-premium/inc/wpseo-functions.php:19
    Stack trace:
    #0 /home/domain/public_html/wp-includes/class-wp-hook.php(287): initialize_wpseo_front(”)
    #1 /home/domain/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
    #2 /home/domain/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #3 /home/domain/public_html/wp-settings.php(540): do_action(‘init’)
    #4 /home/domain/public_html/wp-config.php(93): require_once(‘/home/domain/…’)
    #5 /home/domain/public_html/wp-load.php(37): require_once(‘/home/domain/…’)
    #6 /home/domain/public_html/wp-login.php(12): require(‘/home/domain/…’)
    #7 {main}
    thrown

    Plugin Author Joost de Valk

    (@joostdevalk)

    @rahulrathi looks like your update wasn’t complete. I’d suggest deleting the plugin and reinstalling it. No worries, your settings won’t be gone!

    Okay..let me check this..

    Thanks!

    Hi Joost,

    I am having the same issue. I have also deleted and reinstalled Yoast. the problem remains! This is the error detail in my case:

    Error Details
    =============
    An error of type E_ERROR was caused in line 464 of the file /home/maxlytec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php. Error message: Uncaught PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘blog_id’ in ‘field list’ in /home/maxlytec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php:464
    Stack trace:
    #0 /home/maxec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(464): PDOStatement->execute()
    #1 /home/maxec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(1983): YoastSEO_Vendor\ORM::_execute(‘INSERT INTO `ll…’, Array, ‘default’)
    #2 /home/maxec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/src/orm/yoast-model.php(662): YoastSEO_Vendor\ORM->save()
    #3 /home/maxec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/src/models/indexable.php(160): Yoast\WP\SEO\ORM\Yoast_Model->save()
    #4 /home/maxec/public_html/laterlifeadvice.com/wp-content/plugins/wordpress-seo/src/builders/indexable-builder.php(273): Yoast\WP\SE

    I hope this helps find a fix!

    thanks,
    Christopher

    Hi Joost,

    A follow-up – I have tested the issue on several websites I own. It seems that the security plugin iThemes Security is the cause of the problem. It looks like one of the features of 14.0 involved a database update and indexing. On some of the websites using iThemes Security, the table/column creation was failing. This was due to a setting in iThemes Security. Deactivating iThemes Security and reinstalling Yoast resolved the issue for me.

    I would suggest deactivating security plugins briefly to install this version of Yoast, if it does not install correctly.

    I hope this helps someone else with the issue.

    Thanks,
    Christopher

    I am having the same problem on a site I manage. Removing and reinstalling the plugin did not help in my case. I am not running the iThemes Security plugin. Here are the plugins I am running: Ajax Load More, Classic Editor, Document Gallery, Enable Media Replace, Regenerate Thumbnails, Strong Testimonials, WP Gallery Custom Links.

    Error Details
    =============
    An error of type E_ERROR was caused in line 301 of the file /home/allisonb/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php. Error message: Uncaught Error: Class ‘PDO’ not found in /home/allisonb/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php:301
    Stack trace:
    #0 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/j4mie/idiorm/idiorm.php(229): YoastSEO_Vendor\ORM::_setup_db_config(‘default’)
    #1 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/src/initializers/database-setup.php(52): YoastSEO_Vendor\ORM::configure(‘mysql:host=loca…’)
    #2 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/src/loader.php(145): Yoast\WP\SEO\Initializers\Database_Setup->initialize()
    #3 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/src/loader.php(111): Yoast\WP\SEO\Loader->load_initializers()
    #4 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/src/main.php(81): Yoast\WP\SEO\Loader->load()
    #5 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/src/functions.php(26): Yoast\WP\SEO\Main->load()
    #6 /home/allisonb/public_html/wp-content/plugins/wordpress-seo/wp-

    Hi,

    Kindly let me know if there is any fix for the Yoast error that I have reported.

    the same thing happened to me I had to temporarily disable the plugin until they update

    @lpestudio @joostdevalk

    Done the same thing. Uninstalled the updates to the previous version until we get a permanent fix.

    14.0.2 did not fix this. I no longer get the fatal error (which I should point out exposed the mysql database username and password!), but now I get frequent 500 errors.

    Hi,

    I am also getting this error on atleast 8 of my sites.

    Please advise when this will be patched?

    Regards

    After Yoast 14 update received this error. Disable Yoast and site is working fine.
    Waiting on Yoast bug fix before updating and enabling again.

    An error of type E_ERROR was caused in line 84 of the file …/plugins/wordpress-seo/migrations/20190529075734_WpYoastExpandIndexable.php. Error message: Uncaught Error: Class ‘Yoast\WP\SEO\ORM\Yoast_Model’ not found in …/plugins/wordpress-seo/migrations/20190529075734_WpYoastExpandIndexable.php:84
    Stack trace:
    #0 …/plugins/wordpress-seo/migrations/20190529075734_WpYoastExpandIndexable.php(20): WpYoastExpandIndexable->get_table_name()
    #1 …/plugins/wordpress-seo/vendor_prefixed/ruckusing/lib/Task/Db/Migrate.php(223): WpYoastExpandIndexable->up()
    #2 …/plugins/wordpress-seo/vendor_prefixed/ruckusing/lib/Task/Db/Migrate.php(196): YoastSEO_Vendor\Task_Db_Migrate->run_migrations(Array, ‘up’, NULL)
    #3 …/plugins/wordpress-seo/vendor_prefixed/ruckusing/lib/Task/Db/Migrate.php(114): YoastSEO_Vendor\Task_Db_Migrate->prepare_to_migrate(NULL, ‘up’)
    #4 …/plugins/wordpress-seo/vendor_prefixed/ruckusing/lib/Ruckusing/Task/Manage

    Plugin Support Carl B

    (@devnihil)

    @cdnwhite @heffegg @brownwingstudio This usually happens when the plugin files are cached and some old files are still used after updating the plugin. On occasions, this causes temporary errors that resolve themselves once the cache has been cleared.

    If the problem doesn’t resolve for you automatically, can you please try clearing the cache from your theme, plugin, server and CDN (e.g. CloudFlare) before and after updating Yoast SEO? If you are not sure how to clear the cache from a theme or plugin please speak to those authors. If you want to clear cache from the server, please speak to your host provider.

    @gigglesslut420 @anupamasam @lpestudio ​If you update to the most current version of Yoast SEO version 14.0.4, does this resolve the issue?

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.