Support » Fixing WordPress » Fatal Error after upgrading…help?

  • Hey everyone,

    I just updated my blog and now am receiving a fatal error. The blog was previously running 4.3 (I think) and had been functioning fine. I upgraded my WP software as well as my plugins to then newest versions before this occurred.

    Here is the error message I receive on every page that I try to view (bolded words having been changed to remove my directory titles):

    ” Fatal error: Call to a member function add_nonpersistent_groups() on a non-object in /home/username/public_html/blogdirectory/wp-content/object-cache.php on line 156 ”

    Looking at line 156, I see the following:

    ” $wp_object_cache->add_nonpersistent_groups($groups); ”

    I’ve tried disabling all plugins via phpmyadmin without success.

    Does anyone know how I can fix this?

    Thanks so much!
    Mike

Viewing 6 replies - 1 through 6 (of 6 total)
  • Try a Manual Update: http://codex.wordpress.org/Updating_WordPress#Manual_Update to reupload new copies of all WP files and folders

    Thread Starter troublestudios

    (@troublestudios)

    Thanks for the tip. Just tried updating manually and I get the same error. 🙁

    What else should I try?

    What theme? What webhost?

    Thread Starter troublestudios

    (@troublestudios)

    It’s a custom theme and currently hosting with eleven2.

    I think I’m going to restore the site from backups taken before the upgrade. The only problem is figuring out how to upgrade WP again without this happening again?

    Ask eleven2 what kind of caching they have running, and see if they can disable it.

    So I updated wordpress, and then I got a fatal error. I called my host, they disabled the plugins and themes, but now I can’t even find my website. I don’t have any idea what to do at this point. I really would appreciate any help.

    Oh I read the link in one of the above responses, but I’m not sure I understand if that’s what I’m to do. At this point, I can’t really do anything, since I can’t find the site anylonger.

    • This reply was modified 6 years, 2 months ago by sherri1562.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal Error after upgrading…help?’ is closed to new replies.