Support » Plugin: MultiSafepay plugin for WooCommerce » Fatal error after upgrade to v4

  • Resolved acsnaterse

    (@acsnaterse)


    Since the upgrade to v4, there is a PHP Fatal error in the checkout:

    PHP Fatal error:  Uncaught Http\Discovery\Exception\DiscoveryFailedException: Could not find resource using any discovery strategy. Find more information at http://docs.php-http.org/en/latest/discovery.html#common-errors
     - Puli Factory is not available
     - No valid candidate found using strategy "Http\Discovery\Strategy\CommonClassesStrategy". We tested the following candidates: Http\Discovery\Strategy\CommonClassesStrategy::symfonyPsr18Instantiate, GuzzleHttp\Client, Http\Discovery\Strategy\CommonClassesStrategy::buzzInstantiate.
     - No valid candidate found using strategy "Http\Discovery\Strategy\CommonPsr17ClassesStrategy". We tested the following candidates: .
    
     in /var/www/current/wp-content/plugins/multisafepay/vendor/php-http/discovery/src/Exception/DiscoveryFailedException.php:41
    Stack trace:
    #0 /var/www/current/wp-content/plugins/multisafepay/vendor/php-http/discovery/src/ClassDiscovery.php(79): Http\Discovery\Exception\DiscoveryFailedException::create()
    #1 /var/www in /var/www/current/wp-content/plugins/multisafepay/vendor/php-http/discovery/src/Psr18ClientDiscovery.php on line 27

    Downgraded to v3.8 now and it works again. Not sure it is related to https://wordpress.org/support/topic/no-psr-18-clients-found/, but it also seems to happen in the iDeal payment method.When trying to disable the payment method, it gives the same error.

    WordPress version: 5.6.1
    WooCommerce version: 5.0.0
    MultisafePay version: 4.1.2

    • This topic was modified 6 months, 4 weeks ago by acsnaterse.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author multisafepayplugin

    (@multisafepayplugin)

    @acsnaterse
    Could you provide us with a list of installed plugins, so we can reproduce this error?
    In the mean time, you can keep using 3.8.0
    https://downloads.wordpress.org/plugin/multisafepay.3.8.0.zip

    Plugin Author multisafepayplugin

    (@multisafepayplugin)

    @acsnaterse
    Without a plugin list, we cannot reproduce the issue.
    But we just released 4.1.4 which might fix your issue.
    Please let us know if this will solve your reported issue.

    Plugin Author multisafepayplugin

    (@multisafepayplugin)

    Hello @acsnaterse. Once again thanks for your report and feedback.

    This issue has been reported as resolved by multiple merchants now; and since we don`t have any news from you; I am going to close this ticket.

    Please, if you continue experimenting any issue related, reopen this ticket.

    Thread Starter acsnaterse

    (@acsnaterse)

    Sorry for the late reply, haven’t had the time to test it.

    But the new version indeed solves the bug.
    Thanks for the quick action!

    We are facing the same issue after updating the entire website. It’s in combination with the WooCommerce Mailerlite plugin. When we deactivate your OR the MailerLite plugin, it works well.
    Downgrading to an earlier version isn’t working.

    The error log we get:

    [Mon Mar 01 21:54:58.815477 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr: PHP Fatal error:  Uncaught Http\\Discovery\\Exception\\DiscoveryFailedException: Could not find resource using any discovery strategy. Find more information at http://docs.php-http.org/en/latest/discovery.html#common-errors
    [Mon Mar 01 21:54:58.815511 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr:  - Puli Factory is not available
    [Mon Mar 01 21:54:58.815517 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr:  in /home/user/domains/HIDDEN.com/private_html/wp-content/plugins/woo-mailerlite/vendor/php-http/discovery/src/Exception/DiscoveryFailedException.php:41
    [Mon Mar 01 21:54:58.815524 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr: Stack trace:
    [Mon Mar 01 21:54:58.815529 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr: #0 /home/user/domains/HIDDEN.com/private_html/wp-content/plugins/woo-mailerlite/vendor/php-http/discovery/src/ClassDiscovery.php(74): Http\\Discovery\\Exception\\DiscoveryFailedException::create()
    [Mon Mar 01 21:54:58.815536 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr: #1 /home/user/domains/HIDDEN.com/private_html/wp-content/plugins/multisafepay/vendor/php-http/discovery/src/Psr18ClientDiscovery.php(25): Http\\Discovery\\ClassDiscovery::findOneByType()
    [Mon Mar 01 21:54:58.815543 2021] [fcgid:warn] [pid 121562:tid 139665541551872] [client 185.99.129.21:0] mod_fcgid: stderr: #2 /home/user/domains/HIDDEN.com/private_html/wp-content/plugins/multisafepay/vendor/multisafepay/php-sdk/src/Client/Client.php(96): Http\\Discovery\\Psr18ClientDiscovery::find()
    Plugin Author multisafepayplugin

    (@multisafepayplugin)

    @rienco
    We can reproduce the conflict with MailerLite.
    For now we advise you to stay on 3.8.0, until this conflict has been resolved.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error after upgrade to v4’ is closed to new replies.