Support » Plugin: W3 Total Cache » Fatal error after updating to version 0.13.2

  • Resolved Thorsten :-)

    (@per4mance)


    Hi,
    I updated to you plugin version 0.13.2 and received the following fatal error:

    Fatal error: Uncaught Error: Class ‘W3TC\UserExperience_LazyLoad_Plugin’ not found in /wp-content/plugins/w3-total-cache/Root_Loader.php:35 Stack trace: #0 /wp-content/plugins/w3-total-cache/Root_Loader.php(165): W3TC\Root_Loader->__construct() #1 /wp-content/plugins/w3-total-cache/w3-total-cache.php(67): require_once(‘/home/…’) #2 /wp-settings.php(377): include_once(‘/home/…’) #3 /wp-config.php(88): require_once(‘/home/…’) #4 /wp-load.php(37): require_once(‘/home/…’) #5 /wp-admin/admin.php(34): require_once(‘/home/…’) #6 /wp-admin/index.php(10): require_once(‘/home/…’) #7 {main} thrown in /wp-content/plugins/w3-total-cache/Root_Loader.php on line 35

Viewing 15 replies - 16 through 30 (of 36 total)
  • @hommealone It should remember your settings. Most plugins store their settings in the database. I am not sure how W3TC works in that regard. It did remember my settings. If you are not already running daily or incremental backups I would start for these situations.

    @berdentay no worries

    @hommealone

    Yes it remembers your setting πŸ™‚

    @per4mance:

    Did you do a manual update or did you do it via the admin area?

    Were your settings preserved?

    @hommealone

    The second update I did in backend, but first I deactivated W3 Total Cache, after this I made the update and after this I activated again.

    Now it works for me πŸ™‚

    @hommealone

    All settings I made will remain in database πŸ™‚

    Strange, I’ve removed the plugin folder manually and unzipped the 0.13.2 and it didn’t work. Then I installed the 0.13.1 and updated from within wordpress and it worked. πŸ™‚

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello, @per4mance @hommealone @redonxcom @berdentay

    I am very sorry about the issue you experienced and thank you @per4mance and @redonxcom for providing the solution.
    I think this was the fastest update and some files might be broken after the update. I’ve updated the plugin to 13.2 on couple of my installations and everything works as expected. If someone is still experiencing the issue, make sure to roll back and update the plugin again or update it manually with the zip file.
    All the settings will remain saved as the settings are stored in master.php.
    I am very sorry about the inconvenience and thank you all for your patience.

    @michelboaventura

    This is not the solution I did becasue I did not remove the folder. I deactivated the plugin only, updated it and activated again.

    I don’t know if the idea with removing the folder by deleting really works.

    Thanks @vmarko

    When I re-install the new version (can I just do that using the “add New Plugin” installer in the admin area?) can leave these disable files in place until I see what happens, and then delete them if they’ve been automatically regenerated?

    wp-content/advanced-cache-HOLD.php

    wp-content/object-cache-HOLD.php

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @hommealone

    Yes, you can! Everything should be in order now.
    What happened was a few files were missing from the first commit. We had to make a second commit. So there was a short window where the latest version caused a fatal error.
    Updating should work as expected now.

    Once again I am sorry about the issue, and thank you all for your patience!

    Hello friens.
    I delete the version 0.13.1 and manually install the version 0.13.2 and activate it after that.
    Everything works.
    Regards,
    VΓ­ctor

    Plugin Contributor Harry Jackson

    (@harryjackson1221)

    Hey everybody, thanks for reporting the issue. We really appreciate it!

    The problem causing the fatal error was due to an update to the plugin, and it did not include all of the files in the first commit for some reason. Our development team noticed it pretty quickly, were able to include the necessary files, so it should not happen to anyone else moving forward. The window was only a little more than 10 minutes.

    If you do experience the fatal error on upgrade, rolling back to 0.13.1 then updating again should correct the problem. WP Rollback is pretty good at helping you roll back the plugin if need be.

    Thanks, and I hope you are all staying safe during these trying times!

    Edit: It looks like @vmarko beat me to the response!

    Confirmed that forcing the latest plugin files to be used (be it deleting the old files and then uploading the new ones, just overwriting the existing plugin files, deactivating the plugin and then rolling the plugin back to a previous version and then updating to the new version, etc.) fixed the issue for a site that encountered the issue resolved things.

    Thanks for the detailed explanation of the issue and the quick fix. Maybe a version increment would be helpful for those that have auto-updating plugins/scripts to auto-resolve any installations where the plugin became problematic by updating during that problematic timeframe (I imagine no actual changes would need to be done to the plugin outside of incrementing the version.)

    Thanks again,
    Kurt

    Used wpcli…

    Deactivated plugin
    wp plugin deactivate w3-total-cache

    Forced plugin (re)install
    wp plugin install w3-total-cache --force
    Installing W3 Total Cache (0.13.2)

    Restarted php-fpm

    All good, no issues

    • This reply was modified 6 months, 2 weeks ago by rappaza.

    @redonxcom Worked for me as well. Thanks!

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘Fatal error after updating to version 0.13.2’ is closed to new replies.