Support » Theme: Hueman » Fatal error after updating Hueman theme

  • Hi,

    I found an update notice in my admin area for Hueman theme. I updated the theme as I have done before in the past and when the page tries to load i get the following message:

    Fatal error: Call to protected TGM_Plugin_Activation::__construct() from invalid context in /wp-content/themes/hueman/functions/admin/class-tgm-plugin-activation.php on line 1166

    The error only happens when I try to enter in Admin area. In the public area (the whole website) everything looks OK.

    I’ve found this on http://tgmpluginactivation.com/faq/fatal-php-error-1/ I don’t know if it is helpful:

    This issue was fixed in TGMPA v2.5.2. There are at least two copies of TGMPA active in your WP install and both of them are out-of-date. Please contact the theme/plugin authors of the theme/plugins using the old version of TGMPA and urge them to upgrade the TGMPA version they include.

    Please, I need help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Hi,

    If you know how to use FTP, you can get into your wp-content/themes/ directory and remove hueman theme.

    If not, you can ask your web hosting company to help you revert back to WordPress default theme.

    Once your website is out of fatal error, you will be able to login to your WordPress admin.
    Once logged in, you can proceed to install current version of Hueman Theme which uses TGM-Plugin-Activation version 2.3.6

    Thank you

    Theme Author presscustomizr

    (@nikeo)

    A fix is on the way for this.
    thanks for reporting

    Thanks Nikeo – FYI: if you download a new version of TGMPA using the Custom Generator, it will comply with the theme review rules. Upgrading is highly recommended as v 2.3.6 is over 4 years out of date and contains known security issues. The current version is 2.6.1.

    Theme Author presscustomizr

    (@nikeo)

    Yes I realized the problem a few hours ago…I totally messed up with the version of TGMPA !
    I’ve updated it to the latest version v2.6.1. New release on its way.
    Thanks !

    Thread Starter Konamito

    (@konamito)

    Thanks @nikeo for your help! Now I’ve update to Hueman v3.2.3 and everything works fine!!!

    I feel good in helping improving this amazing theme.

    Regards.

    Thread Starter Konamito

    (@konamito)

    @denzel_chia, as a workaround, last night I changed the plugins directory name to something different e.g. “plugins.deprecated” and I got logged in at admin area.

    But afortunatelly, the theme has been updated and works fine now.

    Regards.

    Hi @konamito,

    You are welcome.
    Glad to be of some help. 🙂

    Best Regards,
    Denzel

    Theme Author presscustomizr

    (@nikeo)

    Thanks for the feedback @konamito.
    thanks for your help @denzel_chia @jrf.
    Resolved

    Hi @nikeo

    You are welcome!

    Best Regards,
    Denzel

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal error after updating Hueman theme’ is closed to new replies.