Support » Plugin: List category posts » Fatal error after update today (10-Oct-2018)

  • Resolved francislee168


    I am a user of godaddy, this afternoon when I login to my wordpress admin page, the List Category posts shows update available, then I click to update.

    But the web was down as show:
    Parse error: syntax error, unexpected ‘[‘ in /home/content/39/9447139/html/blog/wp-content/plugins/list-category-posts/include/lcp-widget.php on line 87

    I even cannot login to admin page anymore.

    I check the support page and told it request php version >5.4 .

    I cannot control the version of godaddy using, show I would like to ask :

    Any method to let me resume the line 87 problem, I cannot ftp to my web and edit the problem file.

    If no, does it possible to remove the plugin safety via FTP.

    I just want to save my website. Thank you for your kind attention.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support zymeth25



    1. Download the 0.78.1 version of the plugin.
    2. Unzip the file you have downloaded.
    3. FTP or SSH into your server, and replace the list-category-posts directory in wp-content/plugins/ with the one you have downloaded and unzipped.
    4. Do not update the plugin later on.

    Next step is to ask your hosting provider to upgrade PHP, or do it yourself if you have acceess to the system.

    Until PHP is upgraded at least to 5.4 you should not install any updates of List Category Posts. Version 0.78.1 is the last one that supports PHP 5.2 and 5.3.

    • This reply was modified 10 months, 1 week ago by  zymeth25.
    • This reply was modified 10 months, 1 week ago by  zymeth25.
    • This reply was modified 10 months, 1 week ago by  zymeth25.
    Plugin Author Fernando Briano


    To add to what @zymeth25 already said, versions older than PHP 5.4 are not supported with security fixes and have reached their end of life. Even PHP 5.4 is not supported anymore. At the moment, PHP 5.6 is the oldest release that’s still receiving security fixes, but only until December.

    WordPress suggests PHP version 7.2 or greater, though it does support older versions.

    We’ll only worry about supporting active versions of PHP. We suggest you update your server’s PHP installation to one of the active ones. Mostly for your website’s security, since older versions don’t even get critical security issues fixes.

    To see currently supported version, you can visit:

    If for some reason you can’t update PHP in your server, you can keep using older versions of the plugin as @zymeth25 mentioned.



    Fatal error, updated and got Line 87 problem, site went down.

    [Fri Oct 12 11:12:13 2018] [warn] [client] mod_fcgid: stderr: PHP Parse error: syntax error, unexpected ‘[‘ in /home/whitstablebusinessclub/public_html/wp-content/plugins/list-category-posts/include/lcp-widget.php on line 87


    Plugin Author Fernando Briano


    @koolwebs please, could you just read the answers here? This error is because your server is using an ancient version of PHP. Either update it to version 5.4 or more, or download the previous version of the plugin and keep it out of date. We suggest you update since your server could be vulnerable.

    with php 5.6 installed, activation fails with this error:
    Parse error: syntax error, unexpected ‘[‘ in /home7/littlfu9/public_html/wordpress/wp-content/plugins/list-category-posts/include/lcp-widget.php on line 87

    Plugin Support zymeth25


    One other person had this issue. Most ptobably it means PHP is not configured correctly. Please contact your hosting provider support.

    We can assure you that the plugin’s code is 100% compatible with PHP 5.6 and has been tested appropriately.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal error after update today (10-Oct-2018)’ is closed to new replies.