WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Fatal error after update 2.3.5

[Resolved] Fatal error after update 2.3.5

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author NextScripts

    @nextscripts

    This issue cased by other plugins incorrectly using post processing functions. (Exec-PHP is the most common troublemaker) We can’t fix the other plugins causing this problem, so we add “Compatibility” mode. Please update to the 2.3.6 and activate it in Plugin Settings->Other Settings.

    Plugin won’t be able to find images in your posts as effectively as in regular mode, but if you are using featured images in your posts, you will be ok.

    Same problem again!
    Problem caused by “Allow PHP in Posts and Pages” plugin.

    Error Message:
    Fatal error: ob_start() [ref.outcontrol]: Cannot use output buffering in output buffering display handlers in /home/ionline1/public_html/wp-content/plugins/allow-php-in-posts-and-pages/allowphp.php on line 419

    Plugin Author NextScripts

    @nextscripts

    Are you sure you turned on “Compatibility” mode? Our plugin does not call other plugins in that mode.

    I just tried to install “Allow PHP in Posts and Pages” and I can confirm that it does break the regular mode site, but it works fine in “Compatibility” mode.

    it works for me but why ?? will you update again ? it has the problem with newstatpress . i deleted newstatpress.php, activate comp mode, install the php i deleted and reactivate it

    I had a similar problem after the 2.3.5 update & the 2.3.6 update did not correct it either. I put NextScripts plugin into compat mode, all good.
    The plugin it affected was wp eMember by tipsntricks-hq.

    Can I just point out that this bug makes the control panel inaccessible, so telling me to change a setting in the control panel is a bit silly?

    For folks who are stuck:

    Note the plugin giving you the error message (it should be something *besides* the SNAP plugin)

    – Go into the file manager for your WordPress installation
    – Find the \wp-content\plugins directory
    – You should find a folder named “social-networks-auto-poster-facebook-twitter-g”
    – Rename this to “social-networks-auto-poster-facebook-twitter-g.tmp”
    – You should now be able to access your control panel

    If you just want to disable the SNAP plugin, you’re done. If you want it back, keep going.

    – Deactivate the plugin that was throwing the error message
    – Change the name of “social-networks-auto-poster-facebook-twitter-g.tmp” back to “social-networks-auto-poster-facebook-twitter-g”
    – Reload the plugins page – the SNAP plugin should be there, but disabled.
    – Enable it.
    – If you haven’t updated it to 2.3.6, you should see a note that an upgrade is available. Upgrade it.
    – Go to the Settings for the SNAP plugin
    – Click the “Other Settings” tab
    – Check [ ] Use compatibility mode
    – Click “Update Settings” at the bottom of the page

    You should now be able to re-activate the other plugin and everyone should be happy.

    In the words of Marco from Tropoj√ę, “Good Luck”

    Plugin Author NextScripts

    @nextscripts

    @macbenoit – I am not sure I got your question. “Why” what?

    Anyway we made “Compatibility” mode default for everybody. It’s just too many plugins out there don’t follow WP development guidelines.

    Many many thanks to NextScripts!
    Latest version 2.3.7 working well…

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Fatal error after update 2.3.5’ is closed to new replies.