Support » Plugin: Yoast SEO » Fatal error after update : 10.0.1>11.6

  • Resolved pexys

    (@pexys)


    Hello,

    After updating the plugin, I had a fatal error on my site in production.
    Yet I did the test on my beta site and it worked.

    Here is the error message:

    Fatal error: Uncaught Error: Class 'ComposerAutoloaderInitf22b8825991ccda35c7813f5b3928f77' not found in C:\HostingSpaces\ESVE\esve.fr\wwwroot\wp-content\plugins\wordpress-seo\vendor\autoload.php:7 Stack trace: #0 C:\HostingSpaces\ESVE\esve.fr\wwwroot\wp-content\plugins\wordpress-seo\wp-seo-main.php(79): require() #1 C:\HostingSpaces\ESVE\esve.fr\wwwroot\wp-content\plugins\wordpress-seo\wp-seo.php(48): require_once('C:\\HostingSpace...') #2 C:\HostingSpaces\ESVE\esve.fr\wwwroot\wp-admin\includes\plugin.php(2050): include('C:\\HostingSpace...') #3 C:\HostingSpaces\ESVE\esve.fr\wwwroot\wp-admin\plugins.php(175): plugin_sandbox_scrape('wordpress-seo/w...') #4 {main} thrown in C:\HostingSpaces\ESVE\esve.fr\wwwroot\wp-content\plugins\wordpress-seo\vendor\autoload.php on line 7

    Can you please watch?

    thank you,

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Yup, same here after upgrading to 11.7.

    Foutdetails
    ===========
    Een fout van het type E_ERROR werd veroorzaakt op regelnummer 22 van het bestand /www/wpss/wp-content/plugins/wordpress-seo/vendor/composer/autoload_real.php. Foutmelding: Uncaught LogicException: Passed array does not specify an existing static method (class 'ComposerAutoloaderInitf21b8825991ccda35c7813f5b3928f77' not found) in /www/wpss/wp-content/plugins/wordpress-seo/vendor/composer/autoload_real.php:22
    Stack trace:
    #0 /www/wpss/wp-content/plugins/wordpress-seo/vendor/composer/autoload_real.php(22): spl_autoload_register(Array, true, true)
    #1 /www/wpss/wp-content/plugins/wordpress-seo/vendor/autoload.php(7): ComposerAutoloaderInitf21b8825991ccda35c7813f5b3928f77::getLoader()
    #2 /www/wpss/wp-content/plugins/wordpress-seo/wp-seo-main.php(79): require('/www/wpss/wp-co...')
    #3 /www/wpss/wp-content/plugins/wordpress-seo/wp-seo.php(48): require_once('/www/wpss/wp-co...')
    #4 /www/wpss/wp-settings.php(362): include_once('/www/wpss/wp-co...')
    #5 /www/wpss/wp-config.php(93): require_once('/www/wpss/wp-se...')
    #6 /www/wpss/wp-load.php(37): require_once('/www/wpss/wp-co...')
    #7 /www/wpss/wp-admin/admin-ajax.php(22): require_once('/www/wpss/wp-lo...')
    #8 {main}
      thrown

    After removing the wordpress-seo folder via FTP, the error displayed when visiting the website changed to.

    Fatal error: Uncaught InvalidArgumentException: A service provider must be a fully qualified class name or instance of (\League\Container\ServiceProvider\ServiceProviderInterface) in /www/wpss/wp-content/plugins/rocket-lazy-load/vendor/league/container/src/ServiceProvider/ServiceProviderAggregate.php:47 Stack trace: #0 /www/wpss/wp-content/plugins/rocket-lazy-load/vendor/league/container/src/Container.php(171): League\Container\ServiceProvider\ServiceProviderAggregate->add('RocketLayyLoadP...') #1 /www/wpss/wp-content/plugins/rocket-lazy-load/src/Plugin.php(81): League\Container\Container->addServiceProvider('RocketLayyLoadP...') #2 /www/wpss/wp-includes/class-wp-hook.php(286): RocketLazyLoadPlugin\Plugin->load('') #3 /www/wpss/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /www/wpss/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /www/wpss/wp-settings.php(394): do_action('plugins_loaded') #6 /www/wpss/wp-config.php(93): require_once('/www/wpss/wp-se...') #7 /www/wpss/wp-load.php(37): in /www/wpss/wp-content/plugins/rocket-lazy-load/vendor/league/container/src/ServiceProvider/ServiceProviderAggregate.php on line 47

    After entering recovery mode I disabled Lazy Load by WP Rocket. Purged all caches in W3 Total Cache. And things were back to normal.

    Enabled Lazy Load by WP Rocket. Cleared caches again. Still good.

    Reinstalled Yoast SEO. Cleared caches again. Still good.

    Hope the team can figure out what went wrong and avoid it in the future.

    Thank you for creating and maintaining this free plugin!

    • This reply was modified 4 months, 3 weeks ago by tfmwa.
    • This reply was modified 4 months, 3 weeks ago by tfmwa.

    Same here, and Wordfence gives the same error.

    Plugin Support Pcosta88

    (@pcosta88)

    @pexys
    We would like some more information.

    1. Can you confirm you are using the most recent Yoast SEO, v11.8? If you update, does the issue resolve?

    2. Can you confirm you are using WordPress 5.2.2? You can check by clicking on the W in the top left and selecting About. If you need to update, please check with your host provider. Please know that if you are using an older version of WordPress Core you may experience unexpected behavior with Yoast. This guide explains more: https://yoast.com/why-we-dont-support-old-wordpress-versions/.

    3. Are all your non-Yoast plugins and themes also updated?

    @moxie
    If you are still experiencing the issue per the forum guidelines, we ask that you please create separate topics for the issues you are experiencing. That way we can focus specifically on your concerns. Plus you will get your own alerts for the issue rather than someone else’s.

    Plugin Support amboutwe

    (@amboutwe)

    This thread has been marked as resolved due to lack of activity.

    You’re always welcome to re-open this topic. Please read this post before opening a new request.

    Thanks for understanding!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.