Support » Plugin: WordPress Twitter Bootstrap CSS » Fatal Error after removing standard less

  • Resolved martijnvhummel

    (@martijnvhummel)


    Hi,
    Sadly I got a fatal error after removing some standard LESS variables in the wordpress admin. I wanted to leave some variables emty, but after that I can’t log into admin anymore.

    What can I do to fix this?

    Fatal error: Uncaught exception ‘Less_Exception_Compiler’ with message ‘Operation on an invalid type’ in C:\xampp\htdocs\website-link\wp-content\plugins\wordpress-bootstrap-css\inc\Less.php\Tree\Operation.php:45 Stack trace: #0 C:\xampp\htdocs\website-link\wp-content\plugins\wordpress-bootstrap-css\inc\Less.php\Tree\Expression.php(52): Less_Tree_Operation->compile(Object(Less_Environment)) #1 C:\xampp\htdocs\website-link\wp-content\plugins\wordpress-bootstrap-css\inc\Less.php\Tree\Call.php(45): Less_Tree_Expression->compile(Object(Less_Environment)) #2 C:\xampp\htdocs\website-link\wp-content\plugins\wordpress-bootstrap-css\inc\Less.php\Tree\Expression.php(52): Less_Tree_Call->compile(Object(Less_Environment)) #3 C:\xampp\htdocs\website-link\wp-content\plugins\wordpress-bootstrap-css\inc\Less.php\Tree\Value.php(27): Less_Tree_Expression->compile(Object(Less_Environment)) #4 C:\xam in C:\xampp\htdocs\website-link\wp-content\plugins\wordpress-bootstrap-css\inc\Less.php\Tree\Operation.php on line 45

    https://wordpress.org/plugins/wordpress-bootstrap-css/

Viewing 6 replies - 1 through 6 (of 6 total)
  • More details:
    I use the plugin: wordpress-bootstrap-css.3.3.5-0

    Plugin Author Paul

    (@paultgoodchild)

    It looks like you’re running it locally there… just rename/delete the plugin folder to disable it and let you log back in.

    thanks for the response Paul.
    Indeed locally.

    I tried to remove the folder, to reinstall the plugin.
    But after installing it, the error pops up again.

    It seems like this is the problem:
    Because I removed a couple of variables, emty variables keep on coming in the variables.less file, like this:
    @body-bg: ;

    When I manually fill in the variables.less, it updates again to emty..

    Do you perhaps know the solution?
    So the variables in variables.less won’t turn up emty.
    I can’t go back into the admin to fill in the variables, bacause of the error.

    Thanks!

    Plugin Author Paul

    (@paultgoodchild)

    Can you try setting the permissions of the file to read only so it doesn’t get overwritten? That might cause other errors, but worth a shot.

    That did the trick, thanks so much for your help Paul!
    I’ve been busy with this problem for hours now.
    Because I changed the file to read-only, I was able to change the variable values in the WP admin > LESS again, without being blocked by the error.

    Keep up the good work 🙂

    Plugin Author Paul

    (@paultgoodchild)

    Great! I’ll look at somehow catching that error in the future.

    Thanks for working through it. Would you mind leaving us a review for the plugin? 🙂

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Fatal Error after removing standard less’ is closed to new replies.