Support » Plugin: Yoast SEO » Fatal Error After New Update

  • Resolved jeevanshetty

    (@jeevanshetty)


    Hi team, after the new update I can’t edit my article it shows this error.

    Fatal error: Uncaught RuntimeException: GuzzleHttp requires cURL, the allow_url_fopen ini setting, or a custom HTTP handler. in /home/walikepr/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/functions.php:105 Stack trace: #0 /home/walikepr/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/HandlerStack.php(37): YoastSEO_Vendor\GuzzleHttp\choose_handler() #1 /home/walikepr/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/Client.php(64): YoastSEO_Vendor\GuzzleHttp\HandlerStack::create() #2 /home/walikepr/public_html/wp-content/plugins/wordpress-seo/src/config/semrush-client.php(69): YoastSEO_Vendor\GuzzleHttp\Client->__construct(Array) #3 /home/walikepr/public_html/wp-content/plugins/wordpress-seo/src/generated/container.php(1256): Yoast\WP\SEO\Config\SEMrush_Client->__construct(Object(Yoast\WP\SEO\Helpers\Options_Helper)) #4 /home/walikepr/public_html/wp-content/plugins/wordpress-seo/src/generated/container.php(649): Yoast\ in /home/walikepr/public_html/wp-content/plugins/wordpress-seo/vendor_prefixed/guzzlehttp/guzzle/src/functions.php on line 105

Viewing 10 replies - 16 through 25 (of 25 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    Thanks for sharing the relevant information. The error you are seeing is coming from the Guzzle HTTP Client that relies on PHP’s cURL extension. Even though you have the cURL extension installed on your site, it doesn’t mean that it is configured properly for PHP.

    In addition, the allow_url_fopen needs to be turned on from the PHP .ini settings to make sure that Guzzle can use the cURL and as well as the allow_url_fopen to perform the HTTP requests.

    So, if you are not familiar with this, we highly recommend you please reach out to your web hosting provider and ask them to configure the cURL with PHP and as well as enable the allow_url_fopen from the .ini settings. In addition, you can also share the relevant error GuzzleHttp requires cURL, the allow_url_fopen ini setting, or a custom HTTP handler so they can understand the issue better.

    Thread Starter jeevanshetty

    (@jeevanshetty)

    Hey, team rolled back to the previous version, and it’s working fine. A new update pushes the website into a difficult situation.

    Pls bring new update

    Thread Starter jeevanshetty

    (@jeevanshetty)

    @mazedulislamkhan i was just researching about allow_url_fopen.

    it says “The allow_url_fopen is a setting managed through the PHP Options which allows PHP file functions to retrieve data from remote locations over FTP or HTTP. This option is a great security risk, thus do not turn it on without necessity.”

    By enabling does it causes any problem?

    Plugin Support djennez

    (@djennez)

    Hi @jeevanshetty , the option allow_url_fopen does not need to be enabled, it’s a fallback if cURL is not available. The error that you’re getting seems to indicate that your website is not able to use cURL *and* does not have allow_url_fopen available.

    This does sound strange to me, since you indicate you have cURL available. Are you able to successfully update plugins / themes via WordPress itself? Can you make sure that your PHP has cURL available?

    Thread Starter jeevanshetty

    (@jeevanshetty)

    @djennez, yes i can update all the plugin and theme in WordPress itself. I even enabled allow_url_fopen and update the Yoast plugin and it’s working fine now.

    What to do now? Already provided all the details about Curl version and other stuff.

    The option allow_url_fopen has been enabled is this causes any security issue on my site?

    Here is the screenshot of Php Extention I see their php73-php-curl is available but not enabled.

    https://prnt.sc/v0l3nk

    I hope you provide me solution

    • This reply was modified 4 months, 2 weeks ago by jeevanshetty.
    • This reply was modified 4 months, 2 weeks ago by jeevanshetty.
    Plugin Support djennez

    (@djennez)

    @jeevanshetty your PHP probably doesn’t have cURL available, and there is no alternative HTTP handler. It was an oversight on our part to not realize that there are hosting parties out there that do not offer this by default (or offer alternatives). We’ve written a fix for this problem and we’re including that in the 15.2 release of our plugin.

    Meanwhile, you can do one of the following:
    – Keep using Yoast 15.0 until 15.2 drops and you can use that.
    – Ask your hosting party to make sure that PHP is able to utilize cURL.

    Other than that I’m afraid there is not much else to do.

    Edit; after looking at your provided screenshot, if you are running PHP 7.2 or 7.3, you should enable the option for PHP to use cURL.

    • This reply was modified 4 months, 2 weeks ago by djennez.
    Thread Starter jeevanshetty

    (@jeevanshetty)

    @djennez iam on Php 7.3, shall is disable allow_url_fopen first.

    Then, i will enable php73-php-curl. Is that ok?

    Thread Starter jeevanshetty

    (@jeevanshetty)

    @djennez it worked thank you

    Plugin Support devnihil

    (@devnihil)

    @jeevanshetty Thanks for confirming that this has corrected it. We are going ahead and marking this issue as resolved but please let us know if you require any further assistance.

    Just mentioning that a hosting provider that I am using also not includes cURL with PHP and I get the same error. I will be waiting for the next version to see if it works. I am now using 15.1.1

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.