Support » Plugin: Helpful » Fatal error after latest update

  • Resolved fragmented.ME

    (@indigotherapies)


    After the latest update my site had a fatal error and wouldn’t load. I’m sure it was on line 638 (but I forgot to screenshot it and just disabled the plugin).

    How can I roll back to yesterdays version until this is fixed?

    Regards
    Denise

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter fragmented.ME

    (@indigotherapies)

    So I deactivated it and did a screen shot.

    The error is :

    Fatal error: ob_start: Cannot use output buffering in output buffering display handlers in
    /homepages/14/d84599638/htdocs/clickandbuilds/fragmentedME/wp-content/plugins/helpful/core/helpers/class-feedback.phponline638

    Plugin Author Pixelbart

    (@pixelbart)

    Hi @indigotherapies

    funnily enough, I didn’t change anything there. But I’m looking at it right now and trying to solve your problem.

    You can download the previous version here:

    4.7.0 Download: https://downloads.wordpress.org/plugin/helpful.4.4.70.zip

    Thank you for your feedback!

    Please stay healthy!

    Greetings Kevin

    Plugin Author Pixelbart

    (@pixelbart)

    I just did some searching but couldn’t find much. This is probably due to the server, which has too little memory. You can increase the memory so, in which you go into the wp-config.php and insert the code there:

    define('WP_MEMORY_LIMIT', '1024M');
    define('WP_MAX_MEMORY_LIMIT', '2048M');

    I can’t see an error here either. I’ll keep looking.

    Greetings Kevin

    Thread Starter fragmented.ME

    (@indigotherapies)

    Thanks I’ll revert back to the old version and turn off updates for a while.

    Memory issues sounds about right. I’m with IONOS and often have issues like this. But I set up there years ago and have since become severely unwell and can’t even envision moving providers.

    Thanks again for such a quick response.
    Denise x

    Plugin Author Pixelbart

    (@pixelbart)

    @indigotherapies

    Yeah, I can’t find anything here either, except for the memory thing. Funnily enough also always in relation to 1&1 or Ionos. They must have severely limited that.

    I also can’t think of an alternative solution for that line of code you highlighted. This is a common technique to query the contents of a file, which I used there. It’s been in use all along though, so I’m not sure why there are problems here.

    The problem is that this is not necessarily buggy within Helpful.

    If I find anything, I’ll let you know. Currently I’m having a hard time finding a solution here.

    Greetings Kevin

    Plugin Author Pixelbart

    (@pixelbart)

    Hello @indigotherapies

    Maybe it has become better with the last two updates, you can look again.

    Greetings Kevin

    Thread Starter fragmented.ME

    (@indigotherapies)

    Hello again

    Thank you for all your help. Yes this update now works without errors.

    Thanks x

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Fatal error after latest update’ is closed to new replies.