Support » Plugin: Simple Cache » Fatal error after last update

  • zhart

    (@zhart)


    Hello.
    I have used this plugin for years, but after the last update I received white pages on whole site, and after turning on debug mode I see the following error:

    Fatal error: Uncaught Error: Call to undefined function sc_serve_file_cache() in /path-to-wordpress-pligins-folder/simple-cache/inc/dropins/file-based-page-cache.php:66 Stack trace: #0 /path-to-wordpress-site/content/advanced-cache.php(15): include_once() #1 /path-to-wordpress-site/wp-settings.php(84): include('/path-to-root-directory/...') #2 /path-to-wordpress-site/wp-config.php(175): require_once('/path-to-root-directory/...') #3 /path-to-wordpress-site/wp-load.php(37): require_once('/path-to-root-directory/...') #4 /path-to-wordpress-site/wp-blog-header.php(13): require_once('/path-to-root-directory/...') #5 /path-to-wordpress-site/index.php(17): require('/path-to-root-directory/...') #6 {main} thrown in /path-to-wordpress-pligins-folder/simple-cache/inc/dropins/file-based-page-cache.php on line 66

    So far, I’ve just deactivated the plugin. Is it possible to solve the problem without disabling the plugin?

Viewing 8 replies - 1 through 8 (of 8 total)
  • I had the same error appearing on my site. I purged the cache, deactivated and re-activated the plugin. Everything seems to be in order again. Don’t know why the error was thrown, though.

    keatsseven

    (@keatsseven)

    I am having the same problem! Inmotion say they can’t do anything about it their end, I an panicking at the moment. How do I proceed as inmotion say they have cleared the cache and deactivated and reactivated the plugin but no joy!

    edit: managed to fix it – had to rename the actual folder to regain access, in case anyone else is stuck. Didnt help with inmotion saying there was nothing they could do…i just assumed it was beyond my control

    • This reply was modified 2 months ago by  keatsseven.
    alongilad

    (@alongilad)

    Hi all,
    I had a similar problem:
    All pages did not display (blank page)after upgrade to 1.7.0.
    Some browsers just displayed a blank page IE returned a 500 error. However for logged in users all was fine.
    Tried to purge cache – did not help.
    rolled back to version 1.6.4 and all works well.

    Another alarming thing is that jetpack site monitor did not recognize that site is down.
    pingdom did recognize.

    Bottom line – wait with upgrade until this is fixed…

    Alon

    Same thing happened to my site. Disable Simple Cache and site works again. Wonder if it is compatibility with WordPress 5.0 update? Are all of you who are on the pre-WP5 having problems too?

    Seems that v 1.7.0 isn’t compatible with PHP > 5.3.

    Same happens for me, after updating the plugin. Does anyone have a suggestion for a good alternative for caching?

    Does anyone have a suggestion for a good alternative for caching?

    The same question. Seems that developer totally ignore user’s problems here. So is it exist good alternative? I mean not heavy monsters like “Total Cache”, “Super Cache”, “Fastest Cache” or “LiteSpeed Cache”, but something simple and lightweight.

    Thanks for posting this. Our site was down too.
    I deactivated Simple Cache, purged cache and reactivated, all is good again.
    WP: 5.0.3
    Simple Cache: 1.7.1
    PHP: 5.6.30

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.