WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Fatal error after 'Empty spam'

[Resolved] Fatal error after 'Empty spam'

  • After deleting all the collected spams, WP comes op with an error message:

    “Call to undefined function json_encode() in /usr/local/www/www.spaink.net/wp-admin/includes/class-wp-list-table.php on line 905”

    Line 905 merely prints something to the screen, so it’s not that bad, but still 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator kmessinger

    @kmessinger

    Thanks for the tip. Yes, I considered the missing class-json.php remarks in that posting. But that’s a theme problem, and this isn’t: the error occurs irrespective of the theme. It’s the file /wp-admin/includes/class-wp-list-table.php calling upon the json_encode function. Plus, the error shows up in the admin panel.

    I’ve tried deactivating all plugins and manually installing WordPress 3,2, and both PHP and MySQL are up to date. Yet the three errors that are pestering me are persisting:
    * no more automatic install
    * I can’t add tags in the New Post screen (only via Quick Edit)
    * and killing spam does its work but returns an error line) insist.

    I’d be grateful for other suggestions!

    Moderator kmessinger

    @kmessinger

    no more automatic install

    Under dashboard, updates there is no “reinstall now” button? If you are up to date, there is no automatic install.

    I can’t add tags in the New Post screen

    Go to upper right corner, screen options and make sure post tags is checked.

    and killing spam does its work but returns an error line

    This is under comments where you can mark as spam or send to trash? “Killing spam” I am unfamiliar with.

    I’m sorry, I was too brief – I had explained my problems elsewhere.

    1: No more automatic install:
    The option to do an automatic update is still present. That directs me to the page ‘Connection Information’, where I enter my FTP / SSh password. I immediately get redirected to an empty admin page, and nothing happens.

    2: Impossible to add tags in the New Post screen:
    Yes, ‘post tags’ is checked. I see the box for adding tags too; but everything that I enter is greyed out, and the link ‘Choose from the most used tags’ doesn’t do anything anymore. However, in ‘Quick Edit’ mode I can add tags.

    3. Error with spam posts:
    On the ‘Comments’ page, I get the aforementioned error as soon as I select to see ‘Trash’. The error also occurs after the command ‘Empty spam’ has been processed.

    Yes, I considered the missing class-json.php remarks in that posting. But that’s a theme problem, and this isn’t

    Just to be clear, PLUGINS can cause this problem too. Json errors are when you have something, normally a theme but not always, calling the non-extant file.

    Since you already did the plugin dance, and the theme dance I believe, try double checking that json is installed on your PHP instance. You can find it on a phpinof() page.

    Moderator kmessinger

    @kmessinger

    Things to try.
    Reset the plugins folder by renaming it xplugins. Sometimes even deactivated plugis cause problems.

    Switch to the twenty eleven theme.

    Reload the wp-includes/js folder.

    kmessinger: Executed all three of your suggestions, and then checked my admin page again. All three problems persisted.

    Ipstenu: Yes, I’ve done all dances, by now repeatedly 🙂 I created a page phpinfo.php on my website – asking for phpinfo(INFO_MODULES) – and here’s the result: http://www.spaink.net/phpinfo.php

    Btw, thanks ever so much for your efforts to nail this problem. Very much appreciated.

    esmi

    @esmi

    Forum Moderator

    The option to do an automatic update is still present.

    So you are still being asked to upgrade WP, yes? Well, that’s not right. sounds like your upgrade never actually completed.

    Try:
    – switching to the Twenty Ten theme

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade.

    esmi: Oh nonono, I’m sorry for the confusion – it’s the automatic update in general that refuses to do its job. WordPress knows that its current installation is up to date, it’s just that it doesn’t want to do any automatic updates – a problem which started pre-3.2. So I actually did the current installation manually…

    All your other suggestions I have tried already. However, my three problems persist, two of which – the json error and the greyed out tag field – are brand new and started with WordPress 3.2.

    KarinSpaink – I’m gonna bet json, cause when I go to that phpinfo page, I DON’T see anything for it.

    Mine has

    json

    json support enabled
    json version 1.2.1

    So yeah, I’d put it there. You need PHP with json enabled for things to work right. It’s supposed to be a standard, but apparently not.

    Ipstenu, I fetched a copy of class-json.php from http://core.trac.wordpress.org/browser/trunk/wp-includes/class-json.php (at the bottom of that page there’s is a download link) and copied that to my /wp-includes directory, and when that didn’t make a difference, to my /wp-admin/includes directoty.

    To no avail.. I’ll ask my hosting provider whether his PHP install has json disabled, and if so: to switch it on. And I’ll report back after that.

    But considering the wild variety of my problems, Ifear that there’s something rotten deep down in my WordPress install. Which is weird, because it worked like a charm before…

    Thanks Ipstenu, your tip did the trick: My hosting provider installed json. No more errors when looking at trashed comments or emptying spam.

    One down, two problems to go!

    Talked to some devs today, and they said a fix for this will be in 3.2.1 so … everyone’s REALLY sorry about it, though in their defense, json’s a default module. Everyone who was in the beta and RCs apparently had it *sigh*

    Owww.. That’s sweet. Plus, anything that makes an install more dependable & secure is welcome 🙂

    My hosting provider really is rather net savvy and he never thought to install json, so perhaps it’s not *very* default – it seems to be an added option that you need to install.

    Meanwhile my second problem – not being able to add tags in the ‘Edit post’ or ‘New post’ screen rather surprisingly fixed itself. Suddenly I see old tags again, can add them etc.

    Remains the third: the automatic update not working, and sending me to a more-or-less blank screen. I’ll chew on that one for a bit more.

    And Ipstenu: thanks again for your help. It was very much appreciated!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Fatal error after 'Empty spam'’ is closed to new replies.
Skip to toolbar