Support » Installing WordPress » Fatal Error after Automatic upgradation to ver 3.2

  • Hi!

    I upgraded to the latest version 3.2 from 3.1.4 and I think the present version is conflicting with buddypress forums plugin.

    Fatal error: Call to undefined method wpdb::WPDB() in /home/smomz/public_html…./wp-content/plugins/buddypress/bp-forums/bp-forums-bbpress.php on line 144

    Please help!


Viewing 9 replies - 1 through 9 (of 9 total)
  • OK, I removed the buddypress plugin and was able to access my new 3.2 version dashboard. I again uploaded the latest 1.2.8 version of BP and again the same error came. Now I have uploaded the version of BP and now my site is working. Thank God!

    Hi There,

    I also tried to upgrade yesterday and nothing seemed to work.

    Now when I try and log into my dashboard I get the following error message:

    Fatal error: Call to undefined function is_network_admin() in /home/lucy/public_html/wp-admin/admin-header.php on line 16

    Please help!

    I am not very tech savvy!


    Hi ablondeabroad,
    Your issue sounds like it’s been caused by a partial upgrade of WordPress, ie. not all the files were updated properly, probably because it got interupted half way through.

    You will need to perform a manual update, in order to do this, you’ll need to download the latest version of WordPRess from, and FTP the files over the top of your existing ones, See this codex article on how to manually update.

    I have tried to re-download wordpress but it just opens a folder with files in.. is this right… I’m not sure what to do next

    I have the same problem as smartmwp above. So the solution is to revert to an earlier version of BuddyPress?

    Buddypress 1.2.9 is out:
    I renamed my /buddypress folder to /buddypress-old, and uploaded 1.2.9 to /buddypress.
    Whew! Disaster averted 😀

    Ok, help! I tried to do an “auto upgrade” (via the button, i guess it’s a plugin? it’s not an option on my other sites so must be something i added) to 3.2 on my testing site (SO glad i have one), and I first got stuck in the “scheduled maintenance” screen, and now it is totally stuck with this error screen:

    Fatal error: Cannot redeclare wp_maybe_load_embeds() (previously declared in /home/cityrat/ in /home/cityrat/ on line 1415

    and i can’t get to the dashboard, etc.
    I’m not the least tech savvy person but I’m no database whiz; also, i have lots of plug-ins running (though i don’t think Buddypress is one of them).

    What should i do?

    The theme I’m using is Magatheme Pro
    but that shouldn’t matter, should it?

    Also: Dreamhost is my host service.

    ok, eek.
    I followed the advice here:

    and deleted the wp-admin and wp-includes folders on the site, downloaded 3.2 manually and uploaded those folders, and now I get THIS error message:

    Warning: require(/home/cityrat/ [function.require]: failed to open stream: No such file or directory in /home/cityrat/ on line 21

    Fatal error: require() [function.require]: Failed opening required ‘/home/cityrat/’ (include_path=’.:/usr/local/lib/php:/usr/local/php5/lib/pear’) in /home/cityrat/ on line 21


    does this upgrade fix
    work for 3.2?

    Whew. It seems to have been fixed. I tried the plugin as above, but it wasn’t even activated (“You are running WordPress 3.2 which doesn’t need the FTP Upgrade Fix plugin. You can deactivate and delete the plugin.”); when the admin panel came back up i activated it. Maybe it took a while to update the new files that i replaced.

    I get this message:
    “An automated WordPress update has failed to complete – please attempt the update again now.”
    When i try to do the upgrade again, it tells me i’m already running the newest version. etc. etc.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Fatal Error after Automatic upgradation to ver 3.2’ is closed to new replies.