Support » Plugin: WP Mautic Form Integrator » fatal error after api setup

  • I get a fatal error when attempting to add a new form after setting up mautic to Ninja form api integration.

    Fatal error: Uncaught Mautic\Exception\IncorrectParametersReturnedException: Incorrect access token parameters returned: Array in /home/webuycar/public_html/NewDreamCoaching.com/wp-content/plugins/wp-mautic-form-integrator/lib/Auth/OAuth.php:505 Stack trace: #0 /home/webuycar/public_html/NewDreamCoaching.com/wp-content/plugins/wp-mautic-form-integrator/lib/Auth/OAuth.php(408): Mautic\Auth\OAuth->requestToken() #1 /home/webuycar/public_html/NewDreamCoaching.com/wp-content/plugins/wp-mautic-form-integrator/wp-mautic-form-integrator.php(379): Mautic\Auth\OAuth->validateAccessToken() #2 /home/webuycar/public_html/NewDreamCoaching.com/wp-content/plugins/wp-mautic-form-integrator/wp-mautic-form-integrator.php(473): haw_mautic_integration_get_forms_from_server(‘haw-mautic-inte…’) #3 /home/webuycar/public_html/NewDreamCoaching.com/wp-includes/class-wp-hook.php(286): haw_mautic_integration_add_new(”) #4 /home/webuycar/public_html/NewDreamCoaching.com/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #5 /home in /home/webuycar/public_html/NewDreamCoaching.com/wp-content/plugins/wp-mautic-form-integrator/lib/Auth/OAuth.php on line 505

    I was able to get it to work after changing to oauth2 but since I know nothing about oauth some of the posts Ive seen about it being less secure is concerning.

    Can you tell me how to resolve the fatal errors, or at least where to being debugging?

Viewing 2 replies - 1 through 2 (of 2 total)
  • me to

    Yep, I’ve got the same error with OAuth1.0a.
    OAuth2.0 worked fine.

    – Me, Mac OS 10.13.2, Laravel Valet , nginx, php-fpm 7.1, MariaDB
    – Fresh installed of WordPress v4.9.1 as http://wordpres.test
    – Installed Contact Form 7 v4.9.2
    – Installed WP Form Integrator v1.0.3
    – Fresh installed of Mautic v2.12.1 as http://mautic.test
    – Issued API credential with an OAuth 1.0a, and try to connect from WP Form Integrator, got error message

    Fatal error: Uncaught Mautic\Exception\IncorrectParametersReturnedException: Incorrect access token parameters returned: Array in /Users/katz515/Sites/wp-content/plugins/wp-mautic-form-integrator/lib/Auth/OAuth.php:505 Stack trace: #0 /Users/katz515/Sites/wp-content/plugins/wp-mautic-form-integrator/lib/Auth/OAuth.php(408): Mautic\Auth\OAuth->requestToken() #1 /Users/katz515/Sites/wp-content/plugins/wp-mautic-form-integrator/wp-mautic-form-integrator.php(379): Mautic\Auth\OAuth->validateAccessToken() #2 /Users/katz515/Sites/wp-content/plugins/wp-mautic-form-integrator/wp-mautic-form-integrator.php(473): haw_mautic_integration_get_forms_from_server('haw-mautic-inte...') #3 /Users/katz515/Sites/wp-includes/class-wp-hook.php(286): haw_mautic_integration_add_new('') #4 /Users/katz515/Sites/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters('', Array) #5 /Users/katz515/Sites/wp-includes/plugin.php(453): WP_Hook->do_action( in /Users/katz515/Sites/wp-content/plugins/wp-mautic-form-integrator/lib/Auth/OAuth.php on line 505

    Mautic Error Log

    [2017-12-20 04:40:54] mautic.ERROR: Uncaught PHP Exception Symfony\Component\HttpKernel\Exception\HttpException: "signature_invalid" at /Users/katz515/Sites/vendor/willdurand/oauth-server-bundle/Service/OAuthServerService.php line 174 {"exception":"[object] (Symfony\\Component\\HttpKernel\\Exception\\HttpException(code: 0): signature_invalid at /Users/katz515/Sites/vendor/willdurand/oauth-server-bundle/Service/OAuthServerService.php:174)"} []

    • This reply was modified 2 years, 10 months ago by Katz Ueno.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘fatal error after api setup’ is closed to new replies.