• Resolved visual.destini

    (@visualdestini)


    Fatal error:
    Declaration of Automattic\WooCommerce\Internal\DependencyManagement\ExtendedContainer::get($id, bool $new = false) must be compatible with League\Container\Container::get($alias, array $args = Array)
    in
    ***plugins/woocommerce/src/Internal/DependencyManagement/ExtendedContainer.php on line 113

    I’ve temporarily disabled the plugin but how do I fix this?

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 24 total)
  • I had the same problem!
    I’m awaiting for solution too.

    • This reply was modified 3 years, 11 months ago by lendasdab42.

    Same issues

    Thread Starter visual.destini

    (@visualdestini)

    I’ve managed to get rid of the fatal error by disabling another plugin (Lazy Load), but I’m still getting errors breaking my site. IE:

    Warning: Declaration of ET_Theme_Builder_Woocommerce_Product_Variable_Placeholder::get_available_variations() should be compatible with WC_Product_Variable::get_available_variations($return = ‘array’)

    I solved for now rolling previous version 4.3.3

    This is happening because the signature of these implemented php functions isn’t compliant with the signature of the interface, or something like that.
    We have to wait a new patch version, I guess.

    I had to rollback too.

    Please, support team, we need a solution, ok?

    Thanks.

    same issue
    just rollback guys

    Hi there!

    WP Rocket 3.6.4 is available now for our customers to upgrade to it.

    It fixes:

    • the WooCommerce 4.4.0 fatal error
    • prevents the PHP notice about the REST API

    Thanks a lot for your patience!

    Same issue, something wrong with the update?

    Me too, same issue, i updated WP Rocket and after WooCoommerce, but i have the same issue.

    The new version 4.4.0 is giving a fatal error and the plugin is not being activated. I had to delete it.
    Fatal error: Declaration of Automattic\WooCommerce\Internal\DependencyManagement\ExtendedContainer::get($id, bool $new = false) must be compatible with League\Container\Container::get($alias, array $args = Array) in /home/u748296269/domains/planetafuturo.org/public_html/wp-content/plugins/woocommerce/src/Internal/DependencyManagement/ExtendedContainer.php on line 113

    Guys, I had the same Problem today and here is a quick solution that I did in 3 minutes and everything is working fine for me.

    Go to this link: https://wordpress.org/plugins/woocommerce/advanced/
    Download the version of woocommerce 4.3.3

    Go to your wordpress dashboard. Upload the plugin. Do not delete the old plugin because I don’t know either your data will be lost or not so the way which I am telling is totally safe.
    Now When you upload the plugin, WordPress will ask you to replace with current version. Click on that and your system will start working fine. If you have any questions regarding this solution feel free to ask.

    Thanks

    4.3.3 version

    I can’t get it installed

    brings me back to trying again

    Pain full error this update

    same issue

    i got a solution & it worked for me.

    Go to this link: https://wordpress.org/plugins/woocommerce/advanced/

    Download the version of woocommerce 4.3.3

    After downloading just go to in your file manager via cpanel or any other.

    domains/xyz/public_html/wp-content/plugins/woocommerce

    there you will see the plugin woocommerce just rename it & you will see your wp dashboard start working.

    now login in it and install & activate the 4.3.3 woocommerce which you have downloaded.

    SOLVED 🙂

    Thanks

    This option didn’t work for me

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Fatal Error after 4.4.0 update’ is closed to new replies.