WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Fatal error with WP Native Dashboard Plugin 3.6 upgrade

[Resolved] Fatal error with WP Native Dashboard Plugin 3.6 upgrade

  • I was on 3.5.2 and did upgrade to 3.6. I now get the following message and don’t know how to fix it: I can’t get any admin access:
    Fatal error: Call to a member function add_menu() on a non-object in /home/content/47/10522347/html/wp-content/plugins/wp-native-dashboard/langswitcher.php on line 28

    The site (http://kanarvag.org) is running normally.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Patrick Nommensen

    @instovo

    Multisite Master

    Using a FTP / File Manager go to wp-content/plugins. Rename the “wp-native-dashboard” folder to “wp-native-dashboard-old.” You should then be able to access the dashboard.

    Most likely a problem with that plugin.

    I had the same problem with the same plugin on a multisite install. After removing the plugin, I was able to complete the update and access the dashboard. The primary site for the multisite installation is working as it should. However, the secondary site has a 404 error when I try to access the homepage. Accessing any other page does not give this error and the page loads as it should. I can login to the dashboard for this secondary site as well. Basically, all the functionality of both site is working with the exception of the homepage for the secondary site. For example, all these pages would load correctly:
    http://www.mysite.com/
    http://www.mysite.com/contact/
    http://www.mysite.com/wp-admin/
    http://www.mysite.com/es/wp-admin/
    http://www.mysite.com/es/contact/
    http://www.mysite.com/wp-admin/network/
    The only page that would not load correctly is:
    http://www.mysite.com/es/

    Also, I typically have a static homepage and blog posts are published on a Blog page. When I chane this and try to access the static page directly it loads. For example:
    typically the secondary site would be http://www.mysite.com/es/
    this would typically load the Home page
    after changing the dashboard setting to use the lates blog posts as the home page, I can go to http://www.mysite.com/es/home and the page loads

    I checked .htaccess and it has not changed since I setup WP Multisite in May of last year.

    Any idea what could cause that?

    Patrick Nommensen

    @instovo

    Multisite Master

    @fjones18: Please create your own topic, this one belongs to davidbick01 🙂

    Sorry, the problem seems similar so I thought I should add it under this topic. I’ve created my own topic here: http://wordpress.org/support/topic/fatal-error-and-404-after-36-upgrade-wp-multisite?replies=1#post-4484475

    Patrick Nommensen

    @instovo

    Multisite Master

    It may seem similar but you are running Multisite and are also having some other and unique side effects 🙂

    I just upgraded completed a manual upgrade from version 3.5.2 to the new 3.6 and when I tried to run the Update your installation step – http://www.claimingkin.com/wp-admin/upgrade.php – my blog site won’t come up and I get the following error message:

    Parse error: syntax error, unexpected ‘,’ in /home/kinfolks/public_html/wp-includes/post.php on line 2936

    When I opened my html editor to take a look at – /wp-includes/post.php on line 2936 – this is what I saw:

    2936 if ( $clear_date ) {
    2937 $postarr[‘post_date’] = current_time(‘mysql’);
    2938 $postarr[‘post_date_gmt’] = ”;

    I know just enough html to be dangerous, so I have not touched or changed any code. But what is causing me all these problems?

    Do I need to go back to my version 3.5.2 at this point?

    Thanks in advance for all your assistance!

    claimingkin (and everyone else NOT using the WP Native Dashboard plugin), please make your own posts 🙂

    Hi Patrick, Sorry! I don’t post much here and therefore am a bit lost as to where to post a brand new topic. I will try to find my way. Again, I apologize for posting incorrectly!

    Thanks Patrick. I tried to do it. Went onto my host’s (GoDaddy)file manager, and could see the problem folder. But there was no facility I could see for renaming. But there was a “delete node” option, so I did that. The folder disappeared. But it made no difference, I still cannot access dashboard. I tried restoring WP 3.5.1. Still no difference. The site seems just the same, by the way.
    Perhaps I don’t understand the ins and outs of the file manager.

    Found it. Problem solved. Thanks.

    Can you post the solution? You’re not the only one reading here 😉

    Hey David, please post the solution – give a little back 🙁

    Hi, I ran into a similar problem and the solution from the second reply post worked for me. This is what I did …Renamed the “wp-native-dashboard” folder to “wp-native-dashboard-old.”

    Hope that works for you.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Fatal error with WP Native Dashboard Plugin 3.6 upgrade’ is closed to new replies.