Support » Installing WordPress » Fatal Error after 3.3 update

  • I just updated to 3.3 and now I’m getting a fatal error when I try to access the dashboard. The screen says “Fatal error: Call to undefined function wp_get_update_data() in /home/content/k/m/b/kmblock/html/wp-admin/menu.php on line 34”

    Based on what I saw other people recommending, I’ve already downloaded a fresh copy of 3.3 to my computer, found the file in question /wp-admin/menu.php and replaced it in my ftp manager through godaddy. This did nothing. Just for kicks I tried again. Nothing. For some extra special fun I removed the file completely to see if the error message would change. It did, no surprise. added it back and I got the same error as before.

    So I pulled up menu.php in dreamweaver and here is the line in question…
    $update_data = wp_get_update_data();

    This is where my know-how ends and my instincts say I should stop and ask for directions before I break something.

    Any help would be greatly appreciated. Thank you!

Viewing 15 replies - 31 through 45 (of 45 total)
  • I had the same issue with Fatal error…
    I want just to add this for the internal knowledge Base for WP.

    type:
    Fatal error: Call to undefined function wp_allowed_protocols() in /home/a7410299/public_html/wp-includes/formatting.php on line 2340

    Other, some technical info about the website where is run WP.
    url: http://marketing-seo.net84.net/
    hosting with 000webhost (really slowly though is free).

    I have also another w.s. with Godaddy where I didn’t have any sort of Fatal error. In this case I pay for a shared hosting with better stuff.

    >>Steps I did to solve the issue<<

    1. Deleted .manteinance file.
    2. Downloaded WP 3.3 zip file, unpacked the zip file.
    Deleted WP-Includes and WP-admin via FTP manager. and manually transferred the above file from the new WP 3.3 folder into the host.

    Website is now running.

    Thanks

    Hi, I found a quick fix that may help some of you. After upgrading to 3.3 through dashboard I received Fatal error: Call to undefined function wp_get_update_data() in /home/edible2/public_html/wp-admin/menu.php on line 34

    I deleted plugins through FTP but that did not solve the problem. So I manually upgraded through FTP and all is fine now. Simple instructions for manual upgrade can be found here http://www.lancelhoff.com/how-to-manually-upgrade-wordpress/

    Good Luck!

    Hello Everyone, I received the same error. To correct it, I just updated my WordPress application within GoDaddy.

    Same error.

    "Fatal error: Call to undefined function wp_get_update_data() in /home/bsergent/public_html/TBA/wp-admin/menu.php on line 34"

    Manuel update and renaming of plugins and themes accomplished nothing but briefly killing my site.

    @courtneylee333

    Step number two is the one that causes the error in question. We can’t “Login to (our) WordPress administration panel”

    Skipping that step, when I reach the final step, I get a message saying I don’t need an upgrade.

    Something like this happens without fail every time an update is suggested. Next update I’m just going to code away the notification and leave it alone in perpetuity.

    Update:

    I went into the menu.php and remarked out the two instances of “wp_get_update_data” and managed to get a ugly version of the dashboard. I attempted to do the automatic update from there and got the same result as before, including returning me to the line 34 error state.

    But this time I copied the errors reported. Maybe they will help someone solve this.

    Downloading update from http://wordpress.org/wordpress-3.3-no-content.zip…
    
    Unpacking the update…
    
    Verifying the unpacked files…
    
    Installing the latest version…
    
    Warning: copy(/home/bsergent/public_html/TBA/wp-includes/images/smilies/icon_smile.gif) [function.copy]: failed to open stream: Permission denied in /home/bsergent/public_html/TBA/wp-admin/includes/class-wp-filesystem-direct.php on line 200
    
    Warning: copy(/home/bsergent/public_html/TBA/wp-includes/images/smilies/icon_smile.gif) [function.copy]: failed to open stream: Permission denied in /home/bsergent/public_html/TBA/wp-admin/includes/class-wp-filesystem-direct.php on line 200
    
    Could not copy file.: /home/bsergent/public_html/TBA/wp-includes/images/smilies/icon_smile.gif

    @courtneylee333

    You didn’t need to delete the plugins as the issue is not related with them because the code line calls the function wp_get_update_data() in menu.php.

    IF you delete the plugins directory, you have to reinstall all of them and you waste your time.

    The easy step it is just to reinstall manually the WP-includes and WP-admin and it should already work it.

    @innomen
    Steps number 2 doesn’t work as you have already the issue and you can’t enter into the wp-admin panel, so it useless, as you will receive the same error message.

    You have to update manually.
    Could you plese list what did you do when tried to update manually? you said you renamed plugins and theme folders? Can you write all the steps you did? so we can help you.

    Thanks

    My steps were trying everything mentioned in this thread as a possible solution. The manual upgrade process is explained all over the web.

    https://codex.wordpress.org/Updating_WordPress#Manual_Update

    When I reach step 2 it says no update is required.

    Barring of course going into the panel and disabling plugins (since I can’t access the panel) which is why I attempted renaming the themes and plugins folders (excepting twentyten of course) as suggested above, and this merely killed my page until I undid those changes. Probably because I have no way to tell it to use the twentyten theme.

    And I only have like two plugins anyway, akismet and disqus, and disqus is still working, along with the rest of my page, from a user perspective. Also my administration tool bar is displaying, and says I only have one update remaining. (It said 2 when I began this whole process.)

    Bottom line: Its not a theme, its not a plugin, manual update didn’t help. I think I *am* updated.

    I think the update itself broke something.

    The manual update process folded at the update steps as it reports no update is required. Probably because the first automated process worked, it is just broken under my conditions and just couldn’t display the cool little smile graphic to indicate completion. The absence of which has nothing to do with the error reported.

    I’m tempted to just go back into the menu.php and cut out all the update references again and muddle through with a butchered ugly dashboard till the next update.

    I will if no solution presents itself here.

    What I have discovered with this upgrade is that it looks for file to over write, and if it does not exist it will FAIL upgrade and stop which and cause the Menu error

    What I was missing on my sites was the “wp-config-sample.php” file so I made sure it was on the there site during upgrade and I had no issues.

    My Fix was to Manually upload 3.3 via FTP, then login to admin and upgrade database. Al works fine after this.

    I just came across this after an update – traced it to the memcache object cache plugin. The update does not clear its own cached objects.

    I have numerous live sites on my server, so restarting memcached is not an option, as users would be forced to log in again.

    I just changed the cache keys so that new objects would be cached under a different name – the old ones will expire or disappear at next kernel update when I reboot the servers.
    Alternatively, just rename wp-content/object-cache.php temporarily to continue admin.

    I have a suggestion for the author of wp-content/object-cache.php, DB_NAME needs adding to the key, otherwise the caches of users using “wp_” prefix on different databases will clash.

    It is recommended to make the document root and the WordPress files in it writable here

    I’ve done all the recommendations here and I’m still getting this one:
    Fatal error: Call to undefined function wp_get_update_data() in E:\Sites\Single1\spatztennis\webroot\wp-admin\menu.php on line 34

    Any thoughts?

    If you get an error like this, there is a plugin or other function called in your theme which you don’t have. How do you fix this? There are a few ways: remove the code, error proof it, get the necessary plugin, or upgrade WordPress if necessary. In this quick WordPress tip post we’ll go over how to error proof these with a conditional tag and PHP function known as: function_exists.

    If you get an error such as Fatal error: Call to undefined function the_title_attribute() you can simply replace any instance of the_title_attribute with the following:

    <?php if (function_exists(‘the_title_attribute’)) { the_title_attribute(); } ?>

    In this case, you could also take it one step further by adding an else statement.

    <?php if (function_exists(‘the_title_attribute’)) { the_title_attribute(); } else { the_title(); } ?>

    Before trying a new theme on a production site, make sure to preview your theme first, and then work out all the errors (if any).

    [signature moderated]

    Fatal error: Call to undefined function wp_get_update_data() in C:\inetpub\vhosts\sampirate.in\httpdocs\wp-admin\menu.php on line 34

    plzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz

    help me i am open my account and show this error plz help me
    [email address removed]

    Headlight…the steps you shared to correct the update situation was spot on. Great job and thank you very much for taking the time to denote the fix step by step.

    I just did a manual reload of the wp-includes folder
    They I hit the update database option
    Click ok when it finished
    Boom! It worked!

    @esmi – you sir, are a legend. As per your instructions, I downloaded the latest update of wordpress manually, then using my FTP client I logged in and uploaded all of the wordpress update files EXCEPT the wp-content folder. It took ~10 minutes to upload and then when I visited /wp-admin it asked me to update the database. From there on out it was plain sailing.

    Thank you so much.

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘Fatal Error after 3.3 update’ is closed to new replies.