Support » Installing WordPress » Fatal Error after 3.3 update

  • I just updated to 3.3 and now I’m getting a fatal error when I try to access the dashboard. The screen says “Fatal error: Call to undefined function wp_get_update_data() in /home/content/k/m/b/kmblock/html/wp-admin/menu.php on line 34”

    Based on what I saw other people recommending, I’ve already downloaded a fresh copy of 3.3 to my computer, found the file in question /wp-admin/menu.php and replaced it in my ftp manager through godaddy. This did nothing. Just for kicks I tried again. Nothing. For some extra special fun I removed the file completely to see if the error message would change. It did, no surprise. added it back and I got the same error as before.

    So I pulled up menu.php in dreamweaver and here is the line in question…
    $update_data = wp_get_update_data();

    This is where my know-how ends and my instincts say I should stop and ask for directions before I break something.

    Any help would be greatly appreciated. Thank you!

Viewing 15 replies - 1 through 15 (of 45 total)
  • same problem. i have Weaver Plus installed. Stuck!!!! I forgot to deactivate my plugins 🙁 . replacing menu.php let me login but then same error came back. HELP HELP 🙂

    Moderator Andrew Nacin

    (@nacin)

    Lead Developer

    It’s not wp-admin/menu.php that is the problem, it’s wp-includes/update.php.

    Can you try a Manual Update of WordPress? Specifically the wp-includes and wp-admin directories. http://codex.wordpress.org/Updating_WordPress#Manual_Update

    no luck. totally fresh install of wordpress. wget latest install gives 3.2.1 !!!! what?? so in manually upgrade it and /wp-admin/menu.php on line 34

    we should call this the 3.3 line 34 install error.

    because fresh or manual, the same problem occurs.

    ;(

    I’m in the same boat and I have NO IDEA what to do? Anybody out there that will take pity on me and help? Thanks!

    esmi

    (@esmi)

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade via wp-admin/upgrade.php

    I do not have Twenty Eleven , as i did remove it.

    So i do what i should have done before:
    backup the dbase
    backup all files.
    i reset the pugins by renaming them with FTP
    i upload all but wp-content from a fress 3.3 install
    re-run the upgrade.

    that would do it?

    esmi

    (@esmi)

    Forum Moderator

    I do not have Twenty Eleven , as i did remove it

    Then you will need to re-upload it – by FTP if necessary.

    So i rename plugins i rename my theme and upload all new 3.3 files then re-run the upgrade?

    esmi

    (@esmi)

    Forum Moderator

    Yes.

    ok running backup now, with my hosts software. then i will re-run and keep you posted

    this post and the previoius one can be delete. thnx

    Ok back in buisiness. All is running smooth and fine. Thnx a lot!

    recap for other users.

    the fix for this error is quite simple.

    the steps are:

    1 backup all files and the dbase (just to be safe)

    2 Log in with FTP: rename the plugin folder to plugin-old and delete .maintenance file
    3 download new 3.3 and unzip it.

    4 Log in with FTP: upload all wp 3.3 files, overwrite all files
    5 log in with wp-admin
    Wp will tell you it needs to update the dbase. press ok
    Wp will give you access to the dashboard.
    Most likely your theme will look like …. and wp will tell you it is broken. An ugly twenty eleven theme can be running now.
    Np
    6Reactivate your theme.
    7Reinstall plugins ( i use nextgen and nextgen scroll nextgen scroll is not tested yet on 3.3 though it runs nice and fine.

    Note on 7 reinstall plugins. On me the install by plugins search install did fail.
    I did manually download the plugins and then did choose upload and install. That did work fine.
    For me this did the trick. quite simple.

    I just updated to wordpress 3.3 and so far im not receiving any errors however when i am using widgetkit from Yootheme to add images to my slide show the upload of image works but when I try to add it(after setting the size and description) all I get is a blank black screen. I have removed the plugin and reinstalled to no avail.any suggestions?

    I just updated to WP 3.3 and am now getting this error message:

    Fatal error: Call to undefined function is_rtl() in /home/ewillms/public_html/wp-includes/general-template.php on line 2102

    Any ideas on how to fix this? My blog is still available on the internet, but I have absolutely no way to log in and maintain.

    I have tried some of the suggestions noted above to no avail.

Viewing 15 replies - 1 through 15 (of 45 total)
  • The topic ‘Fatal Error after 3.3 update’ is closed to new replies.