Support » Installing WordPress » Fatal error: admin-functions and upgrade-functions

  • Resolved Arabrab

    (@arabrab)


    I’m trying to install a complete new version of WP onto my log. But all I get after uploading all the files in the right directory is this message, when I try to run the install.php:

    Warning: require_once(ABSPATH/wp-admin/admin-functions.php) [function.require-once]: failed to open stream: No such file or directory in /storage/…../public/sites/www.bruddstyker.nl/wp/wp-admin/upgrade-functions.php on line 5

    Fatal error: require_once() [function.require]: Failed opening required ‘ABSPATH/wp-admin/admin-functions.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /storage/…../public/sites/www.bruddstyker.nl/wp/wp-admin/upgrade-functions.php on line 5

    I’ve checked and rechecked in several FTP-programs if all the files are there and in the right place. And they are. I’ve tried it with a new database. And still get the same message. And I’ve tried it with the WP-version translated to Dutch (that worked before on another log) and the original english version.

    When I take a look at my log when I get the message above, the log states:

    Fatal error: Call to undefined function wp() in /storage/…../public/sites/www.bruddstyker.nl/wp/wp-blog-header.php on line 16

    I’ve removed the installation now, because the password of my database was showing. And that’s not what I want. But is there someone who can help me solve this problem? I’d really be grateful!

Viewing 15 replies - 1 through 15 (of 18 total)
  • I tried different versions of WP: 2.0 and 2.1.1 and all of them give the same mistake. I really am lost now.

    Is there anyone that can help me?

    Are the permissions correct on your directories? Either the files aren’t there, they’re corrupted, or WP can’t access them. Check privilages.

    To what should they be chmoded? I’ve never had to chmod files before when did the upload.
    The files are there indeed: I can see them in Filezilla, FireFTp and Core FTp Lite. I’ve checked with all three programs.

    Is the site that’s giving you problems currently up somewhere?

    No, because if I leave the files in there my password of the DB is showing in the install.php when you go there. And that’s not what I want, because then anyone can get in there. I could get a screenshot if that would help and put it somewhere to be watched.

    Just a sidenote, I wonder if it always looks for upgrade-functions.php?

    There’s not the possibility that remnants from an old install are sticking around are there? Did you empty the your old database?

    Yes, I did. And I tried it with a new databse too and it got me the same message.

    I’ve made a screenshot and placed it here:

    http://i156.photobucket.com/albums/t39/hupsa/db.jpg

    That’s really wierd. It looks like your server isn’t interpreting the php. But then the errors makes it look like it is.

    In the wp-config.php file, is that block of code that’s displaying in the browser commented out or something?

    I’ve whited out some of my personal information, like password and stuff. Is that what you mean?

    The strange thing is that I had WP running on the same host and website before. I just wanted to replace the Dutch version with the latest English version. It worked just fine. I’m glad I made a proper backup before I decided to do that. I’ve just popped on Pivot to keep logging and am testing WP in the WP section of my log (which is now empty by the way).

    But do you have any idea how I can solve this problem?

    I was talking about the fact that <?php blah blah blah ?> is being displayed in your broswer. Everything between the opening and closing php tags should have been interpreted, not displayed.

    Is that part of the problem then? The fact that it is getting displayed?

    I would think it must have something to do with it. Even if it isn’t directly related, it will be the next problem you face because its your database connection.

    Try downloading a fresh WP installation and using that.

    I did that already. I tried WP 2.0, 2.1, 2.1.1, 2.1.2 and the Dutch version. All freshly downloaded and new installed on a complete new database. And still got the same message with all of them.

    And now I’ve tried it on a complete new site that I just got. And on which there has been no installation of anything at all. I created a complete new databse for it, uploaded all the files in the right way. And what do you think…….still get the same stupid message. I’m getting really frustrated now.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Fatal error: admin-functions and upgrade-functions’ is closed to new replies.