Support » Plugin: WP RSS Aggregator » Fatal error activating plugin

  • Resolved kejpa

    (@kejpa)


    I’ve installed the plugin and it was working fine. Then I had to uninstall it and when I now try to reinstall it I get a fatal error upon activation:

    Fatal error: Can’t inherit abstract function Aventura\Wprss\Core\Model\Event\EventInterface::getData() (previously declared abstract in Aventura\Wprss\Core\DataObjectInterface) in /var/www/html/asf/wp-content/plugins/wp-rss-aggregator/includes/Aventura/Wprss/Core/Model/Event/EventAbstract.php on line 11

    How can I activate the plugin? Is there any rows in the database I need to remove?

    Best regards
    /Kjell

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi Kjell,

    The error you have is explained here.

    In short, it could happen because of an outdated version of PHP (lower than PHP 5.3), which is a requirement for WP RSS Aggregator.

    Did you re-install the plugin on a different site/server/host?

    Also, could you please confirm which PHP version run on your current host/server?

    Hi,
    Yup, I’ve got 5.3.3 and I thought that it would be sufficient for running the site.
    I’ll have to look into updating PHP.

    I guess I never had it running on that server, sorry for misinforming you…

    Thanks a lot!
    /Kjell

    You’re welcome, Kjell.

    No worries. The most important thing is you got that and hopefully you can get the plugin running once you update your PHP version.

    Let us know if you have more questions.

    Also, once you can get it running, if you like our products or the quality of our support, please consider leaving a positive review here.

    It would be greatly appreciated by the whole team.

    Have a great day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.