Support » Networking WordPress » Fatal error activating multisite

  • Hi everyone,

    I’ve been trying hard to activate multisite, but no luck so far.
    I have mod_rewrite enabled on my server, I’ve setup a wildcard dns record and random test subdomains are properly resolving.
    I went through the whole process without any errors, setup blogs.dir directory, added the relevant lines to wp-config.php, and to .htaccess.
    So far so good, but when I click on Login, I get this:

    Fatal error: Call to undefined function get_blog_details() in /home/*****/public_html/wp-includes/ms-settings.php on line 58

    Any idea what could be wrong?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Is this a new install?
    Did you disable plugins?

    And you actually clicked the button in the create a Network screen?

    (just double checking)

    A fatal error means something went wrong, yes. When you read it, it says “call to undefined function” which means it can’t find that function in the wordpress files.

    I’d also make sure you have all the wordpress files uploaded properly.

    Hi Andrea,

    Thanks for answering.
    Yes, I disabled all plugins before starting the multisite activation, and again yes, I clicked the button in the create a Network screen.

    As for your first question, I transferred the site from another server to this new one.

    I’ll try to double check all files, and let’s hope that solves the problem, or else…. I’ll be back for more 😉

    All files look the same as those of a brand new WordPress 3.0.1 version.
    Except for the obvious files, like wp-config.php, .htaccess, etc. that don’t exist on the fresh version.

    I’m puzzled, it never happened to me before.
    I’ll try a fresh install, just to make sure, and add the relevant tables to the database.
    Let’s see what happens.

    That did the trick, thanks again Andrea!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Fatal error activating multisite’ is closed to new replies.