Support » Plugin: Jetpack by WordPress.com » Fatal Error

  • Resolved Good in Today

    (@goodintoday)


    Theme: Suffusion ( figured ya might ask about that )

    So, basically, when I checked today my website says JetPack has an update. Naturally I ran the update. Directly AFTER running the update my lovely website turns into one very boring white screen that reads…

    Fatal error: Call to a member function get_page_permastruct() on a non-object in /<server>/<directory>/<public>/wp-includes/link-template.php on line 271

    So, I went into the back-end and renamed the jetpack directory to jetpack-old ( basically disabled your add-on ) and bam! Just like magic even… Website’s back online. Just to double check I re-named the directory again to just jetpack and back to boring so not sure what’s wrong but for now no jetpack love.

    Website ( if needed ): http://goodintoday.com

    http://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 21 total)
  • Same for me. Not very happy about this, since this makes even wordpress itself unavailable.

    I think I remember a similar thing happening a couple of years ago and giving up on jetpack because of it.

    Same thing happened to me just now. I had to go back to the previous Jetpack version, in order to have my site running again.

    well i can only say.. same here…… :/
    jetpack update worked fine.. and then i wanted to activate wordpress.com on it.. and bam
    Fatal error: Call to a member function get_page_permastruct() on a non-object in /home/mywebsite/public_html/wp-includes/link-template.php on line 271

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Thank you all for the warning! We’re looking into it, and I’ll get back to you as soon as I have some news.

    Plugin Contributor Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    Could you all contact us via email and refer to this thread? I’d like to know more about your site setup (version of WordPress, PHP) in order to try to reproduce the problem.

    Thanks!

    Same here. Disable Jetpack, and the problem goes away…

    okay i sent an email to the support with more details

    Ha. Nevermind. His comment was a link. Sending e-mail. 😀

    same probleme go back to the old version

    I have the same problem, except I can’t even get in to my dashboard to disable the plugin causing the problem. Is there another way to access my site to disable the plugin?

    Never mind, I found it and fixed it.

    Same exact error:

    Fatal error: Call to a member function get_page_permastruct() on a non-object in /home/**********/public_html/wp-includes/link-template.php on line 271

    The jetpack version seemed to update ok and I activated the widget visibility module – all seemed good. Then I tried to activate the new “wordpress.com connect” module and that killed everything. I get a white screen on the front of site and in back-end. deactivating jetpack brings everything back, but I cannot re-enable and use all the stuff I previously enabled and ignore the one that kills it as it goes straight to the white screen.

    WP: 3.6
    PHP: 5.3.18

    Same error, I had to downgrade to get my site back, it totally broke it.

    WP 3.6
    PHP: 5.3.22

    downgraded to 2.3.5 and it works again

    Plugin Contributor George Stephanis

    (@georgestephanis)

    Code Monkey

    Howdy, all!

    I’m George, one of the developers working on Jetpack. Really eager to get this resolved, but I can’t seem to duplicate it on my end. Is there any chance that any of you could generate a username and password for me to your server, both for FTP and your WordPress Dashboard? I’ll try to do any investigating late in the evening tonight to make sure to avoid any visible downtime to your users.

    If you could, please email them to georgestephanis at automattic.com — thanks!

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Fatal Error’ is closed to new replies.