Support » Plugin: Twitter Widget Pro » Fatal Error

  • Resolved Alice Kaye

    (@alice-kaye)


    Fatal error: Cannot redeclare class OAuthUtil in /home/MYSITE/public_html/wp-content/plugins/wordpress-dashboard-twitter/inc/OAuth.php on line 718

    This is the error I’m getting. I can’t get into my admin panel.

    I tried downloading the plugin via the web and uploading via FTP in the hopes that whatever error it caused would go away, but alas that did not help.

    Please help because I haven’t backed up recently and don’t want to have to contact my host to back me up. Ugh.

    Thank you in advance!

    http://wordpress.org/extend/plugins/twitter-widget-pro/

Viewing 3 replies - 1 through 3 (of 3 total)
  • I re-installed a previous version of this (version 2.4.1) for now.

    I almost had to pay my host to restore my account from a backup, so I was getting very upset. But apparently I was smart and backed up recently so I had a semi-recent version of your plugin.

    That being said, I did try to update it one more time to see if it was me or the plugin that was messed up and it’s very much the plugin as I got the exact same error all over again.

    Good luck in your trying to fix it. Very glad that I don’t have to pay to have my site restored. Whew!

    I had the same error, but (like you) it was actually coming from another plugin, also using OAuthUtil

    In my case it was Simple Twitter Connect, which I’d left activated even though not using it (duh, silly me) – so I just deactivated it and problem solved, though I guess that’s not the real solution.

    It looks like yours is coming from wordpress-dashboard-twitter

    So it looks to me like the plugins are squabbling over OAuthUtil – which seems daft, so hope I’m wrong!?

    Plugin Author Aaron D. Campbell

    (@aaroncampbell)

    Yeah, looks like we both had a class named the same thing and it conflicted. It’s my bad, I should have prefixed my classname. I fixed it in 2.5.1 by changing the class name to twpOAuthUtil

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal Error’ is closed to new replies.