Support » Plugin: KCite » Fatal Error

  • Awesome plugin – been working well since the last update. Saw the below error today on only one of my posts. The error blocked the post from loading. It occurred in all browsers except those where I was a logged in user. I thought perhaps this had to do with caching, because current settings have logged in users not seeing cache. So I changed a minify setting and cleared page cache (W3TC plugin). All appears to be working now. Unfortunately it seems the parsing is perhaps less robust than it should be.

    Fatal error: Uncaught exception 'Exception' with message 'String could not be parsed as XML' in /home/[snip]/wp/wp-content/plugins/kcite/kcite.php:809 Stack trace: #0 /home/[snip]/wp/wp-content/plugins/kcite/kcite.php(809): SimpleXMLElement->__construct('') #1 /home/[snip]/wp/wp-content/plugins/kcite/kcite.php(1066): KCite::parse_xml(Object(Citation)) #2 /home/[snip]/wp/wp-content/plugins/kcite/kcite.php(583): KCite::get_pubmed_metadata(Object(Citation)) #3 /home/[snip]/wp/wp-content/plugins/kcite/kcite.php(331): KCite::resolve_metadata(Array) #4 /home/[snip]/wp/wp-content/plugins/kcite/kcite.php(260): KCite::get_html_bibliography() #5 [internal function]: KCite::bibliography_filter('<div class="soc...') #6 /home/[snip]/wp/wp-includes/plugin.php(173): call_user_func_array(Array, Array) #7 /home/[snip]/wp/wp-includes/post-template.php(166): apply_filters('the_content', 'httpv://www.you...') #8 /home/[snip] in /home/[snip]/wp/wp-content/plugins/kcite/kcite.php on line 809

    http://wordpress.org/extend/plugins/kcite/

Viewing 1 replies (of 1 total)
  • Plugin Author philliplord

    (@philliplord)

    I would need further details, particular the kind of references you have in your article. This would help me to find out what the problem is.

    Having said that, I will attempt to update the XML parsing; it should break cleanly when this happens.

Viewing 1 replies (of 1 total)
  • The topic ‘Fatal Error’ is closed to new replies.