Support » Plugin: Pix por Piggly (para Woocommerce) » Fatal error

  • Resolved Valmy

    (@valmy02)


    Olá,

    A última atualização deu um erro fatal no meu site.

    Detalhes do erro
    ================
    Um erro do tipo E_ERROR foi causado na linha 126 do arquivo /home/aquilata/public_html/wp-content/plugins/pix-por-piggly/src/Core/Woocommerce.php. Mensagem de erro: Uncaught Error: Call to a member function isStatus() on null in /home/aquilata/public_html/wp-content/plugins/pix-por-piggly/src/Core/Woocommerce.php:126
    Stack trace:
    #0 /home/aquilata/public_html/wp-includes/class-wp-hook.php(305): Piggly\WooPixGateway\Core\Woocommerce->payment_complete(28686)
    #1 /home/aquilata/public_html/wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #2 /home/aquilata/public_html/wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #3 /home/aquilata/public_html/wp-content/plugins/woocommerce/includes/class-wc-order.php(364): do_action(‘woocommerce_ord…’, 28686, Object(Automattic\WooCommerce\Admin\Overrides\Order))
    #4 /home/aquilata/public_html/wp-content/plugins/woocommerce/includes/class-wc-order.php(222): WC_Order->status_transition()
    #5 /home/aquilata/public_html/wp-content/plugins/woocommerce/includes/admin/meta-boxes/class-wc-meta-box-order-data.php(635): WC_Order->save()
    #6 /home/aquilata/public_html/wp-includes/class-wp-hook.php(305): WC_Meta_Box_Order_D`

    Eu voltei para a versão 2.0.18 e quando fui acessar um pix que já tinha expirado aconteceu isto -> https://prnt.sc/1tgl4fl

    Agradeço a ajuda.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Piggly Dev

    (@pigglydev)

    Muitas pessoas estavam se sentindo incomodas com tantos Pix sendo criados, então lançamos uma rotina de limpeza que elimina os Pix expirados (que não podem mais serem pagos) e os Pix cancelados. Acredito que um Pix expirado, no seu caso, foi ser marcado como pago quando ele já tinha sido expirado. Vamos corrigir isso ainda hoje, deixando uma limpeza manual e não automática.

    Plugin Author Piggly Dev

    (@pigglydev)

    Atualizado @valmy02! Pode voltar a utilizar a partir da versão 2.0.20

    Thread Starter Valmy

    (@valmy02)

    @pigglydev ,

    Vou atualizar, obrigado pela rápida correção 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Fatal error’ is closed to new replies.