Support » Plugin: Google Listings & Ads » Fatal error

  • “Plugin could not be activated because it triggered a fatal error.” But what does that mean? Dunno, deleting.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Same problem here i cant remove the plugin neither or even disable it, worried if I mess up fully if I remove it by hand, how to fix this now

    Plugin Support Mike M. a11n

    (@mikedmoore)

    Automattic Happiness Engineer

    Hi @februaryfour and @catharina1,

    Sorry to learn about the fatal errors. Can you please visit WooCommerce > Status > Logs and locate the fatal error log from the time of these errors, then paste them here?

    Hi Mike, it’s all removed, I had to contact my hosting and they did remove the plugin for me, the google one just didn’t go, couldn’t even disable it, all I have left is a screen print of the error message I can email it if you like.

    Plugin Support B C. a11n

    (@battouly)

    Hi @catharina1,

    Yes , please share a full screenshot of what you see.

    Can you also confirm you do not see any fatal errors in logs to share?

    I recommend https://snipboard.io/ for easily sharing screenshots – please follow the instructions on the page, then paste the URL(s) in your reply.

    I hope this helps you https://snipboard.io/5iZ6g3.jpg

    Plugin Support B C. a11n

    (@battouly)

    Hi @catharina1,

    Thanks for the screenshot, that was helpful.

    The error in the logs is not quite informative, but it looks like this is due to a conflict caused by another plugin.

    As a next step, I recommend running a conflict test by following instructions in the link below:

    https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    Let us know what happened when you try it with only Storefront + WooCommerce + Google Listings & Ads.

    Hi, sad enough I cant run a conflict test anymore, since I removed all and needed the provider to remove the last plugin, if I remind whel it was the google add plugin and the woocommerce pay plugin , those two I was not able to remove , and I’m to nerveus to reinstall them all again

    Plugin Support Felipe (a11n)

    (@felipea8c)

    Hi there,

    I see your point!

    If you are worried about installing them, maybe you can do that on a testing/staging site, so you can make sure that it won’t have issues.

    You can clone your site to a staging environment and perform tests without modifying your live site or impacting customers.

    Many hosts provide staging facilities, so it’s worth checking in with them. It’s also possible to do it using the free WP Staging plugin.

    Plugin Author Jason a11n

    (@jconroy)

    Hi @februaryfour and @catharina1

    Sorry to hear of your difficulties. Just a heads up that we have released 1.1 which contains some additional checks for conflicting plugins which I hope will address your problems.

    All the best,
    Jason

    I have just experienced the same problem and got the following fatal error message which is all gobbledegook to me. Anyone who can help, I’d be very grateful.

    Fatal error: Uncaught Automattic\WooCommerce\GoogleListingsAndAds\Vendor\League\Container\Exception\NotFoundException: Alias (Automattic\WooCommerce\GoogleListingsAndAds\Tracking\Events\ActivatedEvents) is not being managed by the container or delegates in /home/sites/4a/a/a9fe66c1d5/public_html/wp-content/plugins/google-listings-and-ads/vendor/league/container/src/Container.php:188 Stack trace: #0 /home/sites/4a/a/a9fe66c1d5/public_html/wp-content/plugins/google-listings-and-ads/src/Container.php(90): Automattic\WooCommerce\GoogleListingsAndAds\Vendor\League\Container\Container->get('Automattic\\WooC...') #1 /home/sites/4a/a/a9fe66c1d5/public_html/wp-content/plugins/google-listings-and-ads/src/Infrastructure/GoogleListingsAndAdsPlugin.php(61): Automattic\WooCommerce\GoogleListingsAndAds\Container->get('Automattic\\WooC...') #2 /home/sites/4a/a/a9fe66c1d5/public_html/wp-content/plugins/google-listings-and-ads/google-listings-and-ads.php(49): Automattic\WooCommerce\GoogleListingsAndAds\Infrastructure\GoogleListingsAndAdsPl in /home/sites/4a/a/a9fe66c1d5/public_html/wp-content/plugins/google-listings-and-ads/vendor/league/container/src/Container.php on line 188

    Plugin Support Mike a11n

    (@nixiack8)

    Hi @chris244,

    This might happen depending on what is also on the site plugin wise. Have you tried to activate it with just WooCommerce active and see if it still errors out? Please try to do that, and if it still errors out then if it is possible please post your **System Status Report** so we can take a closer look at the site itself and what is on it. You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”.  Once you’ve done that, paste it here in your response.

    We look forward to hearing back from you!

    Hi, Thank you for your assistance. I’ve got this working now.

    Hey @chris244,

    I’m glad you got the plugin working now.

    Do you mind sharing how you got it working so that any users experiencing the same issue can see this?

    Thank you!

    Well, it’s embarrassing to admit, but I had several plugins that weren’t up to date, including Woo Commerce. Once I updated them I was able to activate Google Listings and ads.
    However, even though Woo Commerce tells me it’s syncing with Google, the product feed doesn’t contain any products. I thought I better look at this a bit more closely though before I shout for help again!

    Hello team, i am also expeiencing this problem. Cant disable it either.
    I followed instructions and recover site, neither worked.

    All I can do is just let my host disable it right?

    Current theme: PopularFX (version 1.2.2)
    Current plugin: Google Listings and Ads (version 1.10.0)
    PHP version 7.4.27

    Error Details
    =============
    An error of type E_ERROR was caused in line 16386 of the file /home4/imaxgope/public_html/wp-content/plugins/google-listings-and-ads/vendor/composer/jetpack_autoload_classmap.php. Error message: Allowed memory size of 41943040 bytes exhausted (tried to allocate 2097152 bytes)

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this review.