• Resolved Rextheme

    (@rextheme)


    Getting fatal error after upgrading to the latest version.
    PHP Fatal error: Uncaught Error: Call to a member function getExternalCode() on null in /www/siteurl_432/public/wp-content/plugins/weglot/src/services/class-redirect-service-weglot.php:101

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Remy B

    (@remyb92)

    Hi, thanks for reporting, I fixed the problem. Can you uninstall the current version and install this fix : https://we.tl/t-xnyPNBztl2

    Best

    charleskh

    (@charleskh)

    Having the same issue today after updates on the site. Uninstalled the latest version and installed the fix you linked above but it is still not working. Reverted to version 3.2 for now.

    Thanks

    • This reply was modified 10 months ago by charleskh.
    • This reply was modified 10 months ago by charleskh.
    Plugin Author Remy B

    (@remyb92)

    Hi, we have release a fix. You can update the version to the latests (currently 3.3.1) and it will work

    formulaclick

    (@formulaclick)

    I have same problem and it’s not solved on 3.3.1…

    alphatriumph

    (@alphatriumph)

    I am having the same issue on 3.3.2.

    charleskh

    (@charleskh)

    Just did our monthly updates and it broke upgrading to version 3.3.2. Going to switch back to 3.2…

    “Error thrown
    Call to a member function getExternalCode() on null”

    Hosted on WP Engine.

    Latest version is still broken. plugin: 3.3.4, Core: latest, PHP : 7.4

    PHP message: PHP Fatal error: Uncaught Error: Call to a member function getExternalCode() on null in /home/username/domains/domain.ext/public_html/wp-content/plugins/weglot/vendor/weglot/weglot-php/src/Util/Url.php:265\nStack trace:\n#0 /home/username/domains/domain.ext/public_html/wp-content/plugins/weglot/vendor/weglot/weglot-php/src/Util/Url.php(91): Weglot\\Util\\Url->detectUrlDetails()\n#1 /home/username/domains/domain.ext/public_html/wp-content/plugins/weglot/src/services/class-request-url-service-weglot.php(65): Weglot\\Util\\Url->__construct()\n#2 /home/username/domains/domain.ext/public_html/wp-content/plugins/weglot/src/services/class-request-url-service-weglot.php(75): WeglotWP\\Services\\Request_Url_Service_Weglot->create_url_object()\n#3 /home/username/domains/domain.ext/public_html/wp-content/plugins/weglot/src/services/class-request-url-service-weglot.php(86): WeglotWP\\Services\\Request_Url_Service_Weglot->init_weglot_url()\n#4 /home/username/domains/domain.ext/pub...'

    th3bish0p

    (@th3bish0p)

    Having this too.

    Plugin Author Remy B

    (@remyb92)

    Hi,

    Can you update the plugin to the lastest version, then go on the settings page of Weglot plugin and make sure settings are OK. Then save settings again and it should work

    Hi Remy, getting the same PHP error. Weglot updated to 3.3.6. What I’ve noticed is that if I go to the Weglot settings page I cannot store the destination language. I can select it, but when I press Save it refreshes and the language is not showing.
    I also cannot find any entry in the database where the destination language would be stored. Any idea how I can troubleshoot this please?

    Plugin Author Remy B

    (@remyb92)

    For anyone seeing this error, it’s probably a configuration error. Please send an email to support@weglot.com with your website URL so we can check.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.