• Resolved klartext-ne

    (@klartext-ne)


    Hello, we’ve received the info “fatal error” after installing the last update.

    This woun’t disepear after over an hour:

    AIOSEO V3->V4 Migration In Progress

    All in One SEO is currently upgrading your database and migrating your SEO data in the background.

    This notice will automatically disappear as soon as the migration has completed. Meanwhile, everything should continue to work as expected.

    WordPress-Version 5.6
    Aktuelles Theme: MH Magazine (Version 3.9.8)
    Aktuelles Plugin: All in One SEO (Version 4.0.6)
    PHP-Version 7.4.13

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author arnaudbroes

    (@arnaudbroes)

    Hey @klartext-ne,

    Thank you for reaching out to us.

    Can you give us any more details (full error message for example) about that error you’ve experienced?

    Also, depending on how large your site is, migrating your SEO data might take a while. This is nothing you need to worry about since the plugin automatically falls back to your old data if it hasn’t been migrated yet.

    – Arnaud

    rexru19

    (@rexru19)

    I got the same error.
    https://wordpress.org/support/topic/version-4-06-does-not-work-with-php-7-4/
    are you using PHP 7.4?

    I had to restore the site from a backup.
    I tried to update again on the test site (with PHP 7.4)
    and for two hours I have seen a banner warning about migration.

    Plugin Author arnaudbroes

    (@arnaudbroes)

    @rexru19 I responded to the thread you created earlier.

    We’ve been able to identify the issue and are already working on a fix which should be out later today. It’s actually not a PHP error but a context one (because of where the code ran on your website).

    Also, regarding the migration notice, it may take a while to disappear depending on how large your site is. In the meanwhile, all of your SEO data should still be output correctly since the plugin just falls back to your old data if it hasn’t been migrated yet.

    rexru19

    (@rexru19)

    thanks, I will wait for the update

    DaPikk

    (@dapikk)

    @arnaudbroes +1 to same error – also admin page shows “There has been critical error on Your site” and can not do anything – website towards customers seems to operate fine. WP recovery mode lets me in but is showing also “AIOSEO V3->V4 Migration In Progress” a long time, tho I have a small website only.
    (WP5.6, PHP7.2 – WP site health gives error as: “Your Organization Name and/or Logo are blank. These values are required for AIOSEO’s Organization schema markup.” – which is peculiar error as I had entered those on prior version and they worked!)

    DaPikk

    (@dapikk)

    Quickest way for me was to act as @arnaudbroes recommended in another post:

    … I’d recommend you to disable the plugin for now or rollback to the previous version (download here – https://downloads.wordpress.org/plugin/all-in-one-seo-pack.3.7.1.zip) until we fix this. This is a high priority issue for us so it shouldn’t take too long for us to fix it. …

    So:
    1. Download previous last version
    2. Deactivate current plugin
    3. Install manually via WP downloaded version
    – Click replace with uploaded version if need be
    4. Re-activate the plugin
    All old settings were in place.

    (On other note, as this “new awesome feature-rich” update makse so much mistakes/broken sites and feels like bloatware, when trying to use, I will recommend to all of my customers not to use this plugin and try another one instead.
    For me, as I’m also a developer, using this plugin has saved me some additional time, but now it seems that coding new one would be better and more time saving for me and my customers – as said, new update so as presented, is not what customers/users were used to from such a previously good plugin!)

    Plugin Author arnaudbroes

    (@arnaudbroes)

    Hey @klartext-ne, @rexru19, @dapikk

    We just released a new update that should fix the error you’ve experienced. Once you’ve updated, the migration should start anew and now successfully complete once all your data has been migrated to the new version. Please note that this might take a while depending on how much content (posts/terms) you have.

    Can you guys update and let us know how it goes?

    – Arnaud

    Thread Starter klartext-ne

    (@klartext-ne)

    Looks ok to me. Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Fatal Error’ is closed to new replies.