Support » Plugin: Font Awesome » Fatal error

  • Hi all,

    I just got this error when trying to re activate the font awesome plugin after another plugin crashed the site.

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Namespace declaration statement has to be the very first statement or after any declare call in the script in /home/consumerguidecom/public_html/wp-content/plugins/font-awesome/includes/class-fontawesome-conflict-detection-controller.php on line 2

    I’m using wordpress multisite. I tried to delete the plugin from the network admin page. But the plugin would not delete, I just got “deleting” but it did not complete the compand.

    I don’t have the necessary code knowledge to know what has happened here. Can someone kindly explain what has happened and point me to some instructions on how to fix this?

    Many thanks,

    Jake

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Author mlwilkerson

    (@mlwilkerson)

    Hi @jm2012 can you find out what version of PHP is running on your WordPress site? This plugin requires at least PHP 5.6, and really it should be something like 7.3 or 7.4, based on the official supported releases published at php.net.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.