Support » Plugin: The Holiday Calendar » Fatal error

  • Resolved saveatrain

    (@saveatrain)


    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Cannot declare class api_client, because the name is already in use in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-holiday-calendar/clients/api-client.class.php on line 2

    this is what happened to me when i tried to load the plugin,
    do you know what caused this?

    thanks in advance,

    The page I need help with: [log in to see the link]

Viewing 15 replies - 46 through 60 (of 72 total)
  • Thread Starter saveatrain

    (@saveatrain)

    Ok the change country works, i changed to Italy and saw no holidays this month !!!

    but their is a minor bug:
    we are using https://wordpress.org/plugins/wordpress-popup/ for our exit popup, everytime you change the country the popup comes up,
    I think its because you are not using a standard drop down.

    look at page https://www.saveatrain.com/blog/convert/, when you change gram to something else, it doesn’t show the exit popup.

    lastly, what is the reason you don’t want to change the css for everyone, maybe i have something to covnice you 🙂

    all in good great work guys !

    Plugin Author mva7

    (@mva7)

    Hi,

    this bug is not related to our plugin. The popup should remember whether it has been shown or not. Maybe it’s cookie is also blocked?

    Some countries have months without holidays so this is correct.

    We explained before, it is really hard to create CSS that will work with all themes (because of existing CSS and Javascript that we can’t control). We can do an attempt but no promises.

    We’ll give an update in couple of days.

    Regards,

    Mva7

    btw:
    Yes our drop down is different from the one you show, in the sense that we do a POST. However this is perfectly normal behaviour and should not affect other plugins

    • This reply was modified 2 years, 1 month ago by mva7.
    • This reply was modified 2 years, 1 month ago by mva7.
    Thread Starter saveatrain

    (@saveatrain)

    thanks about the css, you can create the css with percentages instead of fixed numbers and then it should work 🙂

    secondly, regarding your drop down initiating the popup to load
    go to https://www.saveatrain.com/blog/
    on the right side you have english, click on it, it will open a dropdown,

    that again doesn’t open the popup exit

    Thread Starter saveatrain

    (@saveatrain)

    by the way my wordpress shows this error in the logs

    [22-Sep-2020 22:31:03 UTC] PHP Warning: session_start(): Cannot send session cookie – headers already sent in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-holiday-calendar/the-holiday-calendar.php on line 72
    [22-Sep-2020 22:31:03 UTC] PHP Warning: session_start(): Cannot send session cache limiter – headers already sent in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/the-holiday-calendar/the-holiday-calendar.php on line 72

    Plugin Author mva7

    (@mva7)

    Hi,

    still working on the CSS.

    We can make a fix for the drop down. Apparently the popup plugin can’t handle POST’s so we will also enable GET.

    Thanks for the log. While it will not hurt your site it can affect keeping in memory which country was chosen on other websites.

    Regards,

    Mva7

    ps. Next update will be released on Thursday probably.

    Thread Starter saveatrain

    (@saveatrain)

    thanks for the update buddy.
    waiting to hear from you

    Plugin Author mva7

    (@mva7)

    Hi,

    we released a new version for the popup issue. To enable the fix you need to go to:

    /wp-admin/edit.php?post_type=thc-events&page=events (which is the same as Events -> Settings in the menu)

    and turn on “No cookie mode”.

    Regards,

    Mva7

    ps. Still working on the CSS

    • This reply was modified 2 years, 1 month ago by mva7.
    Thread Starter saveatrain

    (@saveatrain)

    i just updated the plugin, and there is no such option of “no cookie mode” in the events->settings

    have a great weekend

    this is what i have

    Date format
    Hide read more link
    Show date on event page Recommended! (However, some websites made some modifications and may want to disable this.)
    Hide background information about holidays

    Plugin Author mva7

    (@mva7)

    Hi,

    our apologies, there was a small error in the code.

    The latest update should work.

    Regards,

    Mva7

    Plugin Author mva7

    (@mva7)

    Hi,

    we will release the CSS option this weekend.

    Regards,

    Mva7

    Thread Starter saveatrain

    (@saveatrain)

    awesome, looking forward to testing it

    Plugin Author mva7

    (@mva7)

    Hi,

    version 1.18 is released. You can enable it on the settings page.

    Regards,

    Mva7

    Thread Starter saveatrain

    (@saveatrain)

    hey,
    what do you mean i can enable it in the settings?

    Plugin Author mva7

    (@mva7)

    Hi,

    The CSS.

    Regards,

    Mva7

    Thread Starter saveatrain

    (@saveatrain)

    i updated the plugin and i dont see settings

    normally when there are settings, inside the plugins section next to the deactivate plugin i have settings button

Viewing 15 replies - 46 through 60 (of 72 total)
  • The topic ‘Fatal error’ is closed to new replies.