Support » Plugin: WooCommerce Smart COD » Fatal Error

  • Resolved Skygrinder

    (@skygrinder)


    Hello, i’m getting a weird fatal error when I try to access the COD settings:

    An error of type E_COMPILE_ERROR was caused in line 151 of the file /usr/www/users/username/wp-content/plugins/wc-smart-cod/admin/class-wc-smart-cod-admin.php. Error message: require_once(): Failed opening required ‘/usr/www/users/username/wp-content/plugins/wc-smart-cod/admin//partials/wc-smart-cod-admin-display.php’ (include_path=’.:/usr/local/lib/php/’)

    The weird thing is i tried this with only Woocommerce and the COD plugin enabled and with a default theme and is till get it.

    I’m running PHP 7.4 and everything is updated to the latest version.

    Any ideas?

    • This topic was modified 4 months, 4 weeks ago by Skygrinder.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Stratos Vetsos

    (@fullstackhouse)

    Hi,

    Please download the patched version here -> https://we.tl/t-nGguaKArGX
    Let us know if it works as expected, in order to release it officially.

    Thanks

    Ok, so i forgot to mention something about the issue. Before i got the fatal error the page would load for a really long time, like 60-100 seconds. Now with the patched version the plugin works but still loads for a very long time when I open the cod page or save the settings (the rest of the pages load in 1-2 seconds).

    • This reply was modified 4 months, 4 weeks ago by Skygrinder.
    Plugin Author Stratos Vetsos

    (@fullstackhouse)

    Did you input a lot of zip codes or any other large data?

    I’ve only added a fee to the cod settings. I got a shipping zone with lots of zip codes though, could that affect the loading time?

    Plugin Author Stratos Vetsos

    (@fullstackhouse)

    No that’s not the case.
    Do you have a lot of shipping methods inside of those zones?

    If yes, you can try our PRO version, where you can have unlimited fees which are loaded asynchronously on the admin eliminating this known issue.

    Yeah i got a few, i’ll check the pro version out, ευχαριστώ.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.