Support » Plugin: WooCommerce » Fatal Error

  • Resolved Atlasfire

    (@atlasfire)


    Got a fatal error after upgrading. Rolled back to Woocommerce 4.3.3 via ftp to solve the issue. Didn’t explore what caused the error, guessing it’s a plugin conflict.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Rahim

    (@rahimvaziri)

    Hi @atlasfire

    Same here.
    My conflict is WP Rocket.

    If you check the email that you have received from WordPress you can trace the conflict.

    I disabled the WP Rocket via file manager by renaming that to wp-rocket-old and now it’s fixed without WP Rocket.

    Hi,
    same problem here with wp rocket, also in our multisite installations …

    Hi,
    Same problem here. The latest 4.4.0 update crashes my site and it seems to be a WP-Rocket conflict. I deactivated Woocommerce through WOrdPress safe mode and all is working again.

    I am getting the following automated fatal error WOrdPress message:

    Error Details
    =============
    An error of type E_ERROR was caused in line 37 of the file /home/statsskolen/public_html/wp-content/plugins/wp-rocket/inc/classes/ServiceProvider/class-options.php. Error message: Uncaught Error: Call to undefined method League\Container\Definition\Definition::withArgument() in /home/statsskolen/public_html/wp-content/plugins/wp-rocket/inc/classes/ServiceProvider/class-options.php:37

    I hope they correct the issue ASAP.

    Hi,
    Exactly the same problem her after update .

    I get the same error.
    This is the complete stack trace:

    Fatal error: Uncaught Error: Call to undefined method League\Container\Definition\Definition::withArgument() in /home/pjmatos/public_html/proal.pt/wp-content/plugins/wp-rocket/inc/classes/ServiceProvider/class-options.php:37 Stack trace: #0 /home/pjmatos/public_html/proal.pt/wp-content/plugins/woocommerce/vendor/league/container/src/ServiceProvider/ServiceProviderAggregate.php(101): WP_Rocket\ServiceProvider\Options->register() #1 /home/pjmatos/public_html/proal.pt/wp-content/plugins/woocommerce/vendor/league/container/src/Container.php(172): League\Container\ServiceProvider\ServiceProviderAggregate->register('options') #2 /home/pjmatos/public_html/proal.pt/wp-content/plugins/wp-rocket/inc/Plugin.php(100): League\Container\Container->get('options') #3 /home/pjmatos/public_html/proal.pt/wp-content/plugins/wp-rocket/inc/main.php(48): WP_Rocket\Plugin->load() #4 /home/pjmatos/public_html/proal.pt/wp-includes/class-wp-hook.php(287): rocket_init('') #5 /home/pjmatos/public_html/proal.pt/wp-includes/class-wp-hook.php(311): WP_H in /home/pjmatos/public_html/proal.pt/wp-content/plugins/wp-rocket/inc/classes/ServiceProvider/class-options.php on line 37

    Same issues, i tried to rename wp-rocket and deleted cache but I have still problem

    I solved for now rolling previous version 4.3.3

    I am facing the same issue after Woocommerce 4.4 update it is causing conflict with WP Rocket plugin and giving FATAL error. Asked my host to disable WP Rocket. I am now able to login to my WP dashboard. I rolled back to WooCommerce 4.3.3 but looks like the products page is displayed blank and unable to navigate to any of my product pages. What’s wrong? I raised a ticket to WP Rocket mentioning the error. I doubted and checked the forum and found that the WooCommerce update is causing the issue? Please fix it.

    • This reply was modified 1 year, 3 months ago by eranimesh6.

    I had a message from the Plugin WP Rocket:

    📢 WooCommerce 4.4.0 is breaking sites!

    The latest WooCommerce update, 4.4.0 is breaking themes and plugins, including WP Rocket.

    We are working on a new version 3.6.4 to avoid the conflict which will be available soon.

    Please update to WP Rocket 3.6.4 before updating WooCommerce.

    wp rocket 3.6.4 fix the problem

    https://wp-rocket.me/changelog/

    It works 😉

    Hi there!

    WP Rocket 3.6.4 is available now for our customers to upgrade to it.

    It fixes:

    • the WooCommerce 4.4.0 fatal error
    • prevents the PHP notice about the REST API

    Thanks a lot for your patience!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Fatal Error’ is closed to new replies.